Bug 138160 - ALPS touchpad Mouse not recognized by kernel
ALPS touchpad Mouse not recognized by kernel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-05 01:51 EST by Gregory Gulik
Modified: 2015-01-04 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-16 04:11:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gregory Gulik 2004-11-05 01:51:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
I have a Compaq R3000Z notebook with an ALPS Touchpad mouse which is
not recognized by the FC3 kernel.  I've tried several versions
including the latest and none will recognize the mouse.

After a lot of research I figured out that by recompiling the kernel
with the evdev and psmouse loadable modules rather than built-ins.

The process I use to get it working is documented here:
http://www.gagme.com/greg/linux/compaqr3000z-fc3.php

This just gets it recognized as a standard PS/2 mouse, I'm still
lacking the full ALPS Touchpad functionality.


Version-Release number of selected component (if applicable):
kernel-2.6.9-1.667

How reproducible:
Always

Steps to Reproduce:
1. Boot kernel
2. Attempt to use mouse either in text mode or X
3.
    

Actual Results:  Cursor never moves.

Expected Results:  Cursor should move when using the ALPS touchpad
built into this laptop.

Additional info:

With the evdev and psmouse modules compiled as loadable modules the
mouse gets recognized as follows:
mice: PS/2 mouse device common for all mice
input: PS/2 Generic Mouse on isa0060/serio4

This mouse is NOT recognized by any FC3 kernels.
Comment 1 Alex Butcher 2004-11-28 14:39:45 EST
You need to rebuild the kernel with the alps.patch supplied with the
synaptics package.
Comment 2 Dave Jones 2005-07-15 16:31:40 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 3 Alex Butcher 2005-07-16 03:16:33 EDT
I think this patch, or something equivalent, is in 2.6.12-1.1372_FC3 now.

Note You need to log in before you can comment on or make changes to this bug.