Bug 138162 - "mkfs(parted command)" command is supported file system "ext3" ?
"mkfs(parted command)" command is supported file system "ext3" ?
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: parted (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-05 03:16 EST by L3support
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-16 08:56:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description L3support 2004-11-05 03:16:23 EST
Description of problem:

We think "mkfs(parted commnad)" command isnot supported file system
"ext3".
Because it is indicated by "man" commnad or "info" commnad such. 

# man parted
-- excerpt -- 
mkfs partition fs-type
 make a filesystem fs-type on partition.  fs-type  can  be
 one of "FAT", "ext2" or "linux-swap".

But it was shown as follows 
when we specified "mkfs" of argument of help(parted command) command.

# parted
-- abbreviated --
(parted) help mkfs
-- excerpt -- 
FS-TYPE is one of: ext3, ext2, fat32, fat16, hfs, jfs, linux-swap, 
ntfs, reiserfs, hp-ufs, sun-ufs, xfs

According to the above-mentioned description, 
we can think "mkfs" command is supported file system "ext3".

Is "mkfs" command  supported file system "ext3" ?
Or is the result of "(parted) help mkfs" wrong ?

Version-Release number of selected component (if applicable):
parted-1.6.12-2

How reproducible:
always

Steps to Reproduce:
1. parted
2. (parted) help mkfs


Actual results:
"mkfs" command is supported file system "ext3".


Expected results:
"mkfs" command can run propely.
Comment 1 Jeremy Katz 2004-11-08 09:24:44 EST
The man page probably hasn't been updated.  Although creation of
filesystems from within parted is something I would not recommend
doing as it won't set them up to use all of the new features that
using mke2fs directly will.
Comment 2 L3support 2004-11-17 06:35:02 EST
Is what you say that we can create "ext3" filesystem 
using "mkfs(within parted)" command ?

Or  Can not we create "ext3" filesystem 
using current parted command version(1.6.12-2) ?

We tried to create "ext3" filesystem using "mkfs" command.
But we could not create "ext3" filesystem.

Following message is shown,
when we run "(parted) mkfs (minor) ext3".

No Implementation: Support for creating ext3 file systems is not
implemented yet.

So, I think the result of "(parted) help mkfs" is wrong.
Comment 3 L3support 2004-12-02 07:11:28 EST
Could you tell me status of problem ?
Comment 4 L3support 2004-12-19 20:32:55 EST
We'd like to know status of the problem.
Comment 5 L3support 2005-01-05 01:27:50 EST
We'd like to know status of the problem.
Comment 6 Andrew Clausen 2005-01-05 05:28:47 EST
The file system type list:

"FS-TYPE is one of: ext3, ext2, fat32, fat16, hfs, jfs, linux-swap, 
ntfs, reiserfs, hp-ufs, sun-ufs, xfs"

is just a list of file system type names.  It is not intended to
represent a list of supported file systems.  Perhaps this is
misleading, and should be changed to indicate which of the file
systems have support for mkfs.  I am accepting patches...
Comment 7 RHEL4-L3support 2005-01-18 20:45:27 EST
Add RHEL4-L3support team in Japan
Comment 11 JoAnne K. Halligan 2005-02-14 13:06:31 EST
This has been closed by engineering due to lack of upstream acceptance as it is
more of a documentation issue than a functional one. 

Engineering has also committed a patch to upstream to help fix the 'help' output
and would look to pick this up in the future. 

Note You need to log in before you can comment on or make changes to this bug.