Bug 1381738 - rhel-osp-director: minor update of overcloud fails to start: No such file or directory: '/usr/share/openstack-tripleo-heat-templates/overcloud-without-mergepy.yaml
Summary: rhel-osp-director: minor update of overcloud fails to start: No such file o...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: 10.0 (Newton)
Assignee: Brad P. Crochet
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-04 21:01 UTC by Alexander Chuzhoy
Modified: 2016-12-29 17:02 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-common-5.2.1-0.20161007114757.cc19d04.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:08:19 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 382486 None None None 2016-10-06 10:34:35 UTC

Description Alexander Chuzhoy 2016-10-04 21:01:52 UTC
rhel-osp-director:   minor update of overcloud fails to start: No such file or directory: '/usr/share/openstack-tripleo-heat-templates/overcloud-without-mergepy.yaml

Environment:
instack-undercloud-5.0.0-0.20160929132429.56e65af.el7ost.noarch
openstack-puppet-modules-9.0.0-0.20160915155755.8c758d6.el7ost.noarch
openstack-tripleo-heat-templates-5.0.0-0.20160929150845.4cdc4fc.el7ost.noarch

Steps to reproduce:

1. Deploy 10 (2016-09-30.2) with:
openstack overcloud deploy --templates --control-scale 3 --compute-scale 1 --neutron-network-type vxlan --neutron-tunnel-types vxlan --ntp-server clock.redhat.com --timeout 90 -e /usr/share/openstack-tripleo-heat-templates/environments/puppet-pacemaker.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e network-environment.yaml --ceph-storage-scale 1


2. Update the undercloud to latest puddle (see environment).
3. Attempt to update the overcloud:
openstack overcloud update stack overcloud -i --templates -e /usr/share/openstack-tripleo-heat-templates/overcloud-resource-registry-puppet.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/puppet-pacemaker.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e network-environment.yaml


Result:
starting package update on stack overcloud
<urlopen error [Errno 2] No such file or directory: '/usr/share/openstack-tripleo-heat-templates/overcloud-without-mergepy.yaml'>


There's no /usr/share/openstack-tripleo-heat-templates/overcloud-without-mergepy.yaml on the system.

Comment 1 James Slagle 2016-10-05 15:46:32 UTC
dougal, can you take a look at this one? i think this is what you were already working on upstream as well.

Comment 2 Dougal Matthews 2016-10-05 15:57:27 UTC
This is the same as the upstream bug: https://bugs.launchpad.net/tripleo/+bug/1626128

thrash has been working on that primarily - I have been trying to help a bit. So I've reassigned to him and moved to on_dev.

Comment 3 Alexander Chuzhoy 2016-10-05 23:40:27 UTC
With files in https://review.openstack.org/#/c/382486/ the update continued.

Comment 5 Alexander Chuzhoy 2016-10-24 14:00:11 UTC
Verified:
Environment:
openstack-tripleo-common-5.3.0-1.el7ost.noarch

The reported issue doesn't reproduce.

Comment 7 errata-xmlrpc 2016-12-14 16:08:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.