Bug 1381767 - (filezilla) can't drag filename with percent symbol ("%") between panes
Summary: (filezilla) can't drag filename with percent symbol ("%") between panes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wxGTK3
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jeremy Newton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-04 23:38 UTC by utwubie
Modified: 2016-10-14 05:01 UTC (History)
2 users (show)

Fixed In Version: wxGTK3-3.0.2-26.fc24 wxGTK3-3.0.2-26.fc23 wxGTK3-3.0.2-26.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-13 21:53:54 UTC
Type: Bug


Attachments (Terms of Use)

Description utwubie 2016-10-04 23:38:26 UTC
Attempting to drag a file from the local to remote pane does not work if the filename has a percent symbol ("%").

For example, if you attempt to drag a file named test%20test.txt from local to remote, nothing happens -- no message is appended to the message log; no item is added to the transfer queue.

This issue is especially problematic when the user highlights and drag-and-drops multiple files, as they may not notice that not all of the files they selected get queued.

If the user instead right-clicks on test%20test.txt and selects "Upload", the file is uploaded normally.

According to filezilla developer "codesquid":
This is due to a bug in wxWidgets. I've fixed it in ​https://github.com/wxWidgets/wxWidgets/commit/3b047b58ceb4a0bf11a607b3a5a47697d70de946
(https://trac.filezilla-project.org/ticket/10657)

the wxWidgets team notes the following about the latest release:
'Please notice that while 3.1.0 is officially a "development" version because it is not fully compatible with 3.0.x, the list of backwards incompatible changes is very short, so you shouldn't have any problems updating to this version from 3.0.x in practice, and you're encouraged to try this version out and use it in production in spite of its odd version number.' (https://www.wxwidgets.org/news/2016/02/wxwidgets-3.1.0-released/)

Jeremy Newton worries that updating wxwidgets may cause regressions and suggests backporting fixes. (https://bugzilla.redhat.com/show_bug.cgi?id=1381583)

Comment 1 Jeremy Newton 2016-10-04 23:41:45 UTC
I can backport this fix. Thanks for finding the commit for me.

Comment 2 Scott Talbert 2016-10-05 02:14:27 UTC
So, it looks like that patch has a memory leak, so we probably want this one too:
https://github.com/wxWidgets/wxWidgets/commit/0f9f942a5bbe0ed9f07ea2e1fef90a7e2db768e5

Comment 3 Jeremy Newton 2016-10-05 02:15:33 UTC
Oh nice catch, I'll pull that in too. Thanks

Comment 4 Fedora Update System 2016-10-05 10:22:06 UTC
wxGTK3-3.0.2-25.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d167466599

Comment 5 Fedora Update System 2016-10-05 11:20:59 UTC
wxGTK3-3.0.2-25.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-733a201e01

Comment 6 Jeremy Newton 2016-10-05 12:12:31 UTC
Hold tight until 3.0.2-26, I pushed it last night and the updates are a little delayed right now.

Comment 7 Fedora Update System 2016-10-05 20:28:07 UTC
wxGTK3-3.0.2-25.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2d4f4c37da

Comment 8 Fedora Update System 2016-10-05 22:24:37 UTC
wxGTK3-3.0.2-26.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-70cabdc07a

Comment 9 Fedora Update System 2016-10-06 01:50:38 UTC
wxGTK3-3.0.2-26.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-324dcf78ae

Comment 10 Fedora Update System 2016-10-06 01:51:53 UTC
wxGTK3-3.0.2-26.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-634d0e7251

Comment 11 utwubie 2016-10-06 04:15:59 UTC
3.0.2-26 addresses the issue -- thanks!

Comment 12 Fedora Update System 2016-10-13 21:53:54 UTC
wxGTK3-3.0.2-26.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2016-10-14 01:20:34 UTC
wxGTK3-3.0.2-26.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2016-10-14 05:01:13 UTC
wxGTK3-3.0.2-26.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.