Bug 1381873 (CVE-2016-7948) - CVE-2016-7948 libXrandr: Insufficient validation of server responses result in various data mishandlings
Summary: CVE-2016-7948 libXrandr: Insufficient validation of server responses result i...
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2016-7948
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1381874
Blocks: 1381939
TreeView+ depends on / blocked
 
Reported: 2016-10-05 08:56 UTC by Andrej Nemec
Modified: 2021-02-17 03:14 UTC (History)
4 users (show)

Fixed In Version: libXrandr 1.5.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-08 02:59:33 UTC


Attachments (Terms of Use)

Description Andrej Nemec 2016-10-05 08:56:14 UTC
It was found that when receiving a response from the server protocol data is not validated sufficiently. This results in various data mishandlings.

Upstream patch:

https://cgit.freedesktop.org/xorg/lib/libXrandr/commit/?id=a0df3e1c7728205e5c7650b2e6dce684139254a6

External References:

https://lists.x.org/archives/xorg-announce/2016-October/002720.html

CVE assignment:

http://seclists.org/oss-sec/2016/q4/17

Comment 1 Andrej Nemec 2016-10-05 08:56:55 UTC
Created libXrandr tracking bugs for this issue:

Affects: fedora-all [bug 1381874]


Note You need to log in before you can comment on or make changes to this bug.