Bug 1381886 - No X11 DISPLAY variable was set
Summary: No X11 DISPLAY variable was set
Keywords:
Status: CLOSED DUPLICATE of bug 1026751
Alias: None
Product: Fedora
Classification: Fedora
Component: sagemath
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Paulo Andrade
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-05 09:35 UTC by Germano Massullo
Modified: 2016-10-05 09:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-05 09:37:34 UTC


Attachments (Terms of Use)

Description Germano Massullo 2016-10-05 09:35:23 UTC
Description of problem:
Running

x,y=var('x, y')
plot3d((x^2)*y-x*y+x*y^3,(x,0,5),(y,0,5))

returns

Exception in thread "main" java.lang.ExceptionInInitializerError
Caused by: java.awt.HeadlessException: 
No X11 DISPLAY variable was set, but this program performed an operation
which requires it.
	at sun.awt.HeadlessToolkit.getScreenSize(HeadlessToolkit.java:284)
	at
org.openscience.jmol.app.jmolpanel.JmolPanel.<clinit>(JmolPanel.ja\
va:173)
/usr/lib64/python2.7/site-packages/sage/repl/rich_output/display_manager\
.py:570: RichReprWarning: Exception in _rich_repr_ while displaying
object: Jmol failed to create file
'/home/sage/.sage/temp/host/1582/dir_631amd/preview.png', see
'/home/sage/.sage/temp/host/1582/tmp_q2GQOi.txt' for details
  RichReprWarning,
Graphics3d Object


Version-Release number of selected component (if applicable):
sagemath-6.8-14.fc24.x86_64

Comment 1 Germano Massullo 2016-10-05 09:37:34 UTC

*** This bug has been marked as a duplicate of bug 1026751 ***


Note You need to log in before you can comment on or make changes to this bug.