Bug 1381927 (CVE-2016-7949) - CVE-2016-7949 libXrender: Insufficient validation of server responses results in overflow of previously reserved memory
Summary: CVE-2016-7949 libXrender: Insufficient validation of server responses results...
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2016-7949
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1381930
Blocks: 1381939
TreeView+ depends on / blocked
 
Reported: 2016-10-05 11:32 UTC by Andrej Nemec
Modified: 2019-09-29 13:57 UTC (History)
4 users (show)

Fixed In Version: libXrender 0.9.10
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-08 02:59:38 UTC


Attachments (Terms of Use)

Description Andrej Nemec 2016-10-05 11:32:53 UTC
It was found that when receiving a response from the server protocol data is not validated sufficiently. Individual lengths inside received server data can overflow the previously reserved memory.

Upstream patch:

https://cgit.freedesktop.org/xorg/lib/libXrender/commit/?id=9362c7ddd1af3b168953d0737877bc52d79c94f4

External References:

https://lists.x.org/archives/xorg-announce/2016-October/002720.html

CVE assignment:

http://seclists.org/oss-sec/2016/q4/17

Comment 1 Andrej Nemec 2016-10-05 11:34:56 UTC
Created libXrender tracking bugs for this issue:

Affects: fedora-all [bug 1381930]


Note You need to log in before you can comment on or make changes to this bug.