Bug 1382058 - The tht-compat package RPM deploys the templates in the wrong directory
Summary: The tht-compat package RPM deploys the templates in the wrong directory
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates-compat
Version: 10.0 (Newton)
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: 10.0 (Newton)
Assignee: Mike Burns
QA Contact: Dan Yasny
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-05 15:48 UTC by Dan Yasny
Modified: 2016-12-29 16:55 UTC (History)
4 users (show)

Fixed In Version: openstack-tripleo-heat-templates-compat-2.0.0-34.2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:10:14 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
RDO 3070 None None None 2016-10-05 16:15:12 UTC

Description Dan Yasny 2016-10-05 15:48:12 UTC
Description of problem:
The openstack-tripleo-heat-templates package is always deployed in /usr/share/openstack-tripleo-heat-templates

Before OSP10 the backwards compatible packages were also there, under their respective names, e.g. /usr/share/openstack-tripleo-heat-templates/liberty

the new compat package is expected there as well, i.e. in /usr/share/openstack-tripleo-heat-templates/mitaka but it actually installs in 
/usr/share/tripleo-heat-templates/... missing the "openstack" in the directory name, and thus landing in a different location in the file tree.

Version-Release number of selected component (if applicable):

openstack-tripleo-heat-templates-compat-2.0.0-34.1.el7ost.noarch

How reproducible:

always

Steps to Reproduce:
1. install openstack-tripleo-heat-templates-compat
2.
3.

Actual results:
$ rpm -ql openstack-tripleo-heat-templates-compat-2.0.0-34.1.el7ost.noarch
...
/usr/share/tripleo-heat-templates/compat
...
/usr/share/tripleo-heat-templates/mitaka
...


Expected results:
$ rpm -ql openstack-tripleo-heat-templates-compat-2.0.0-34.1.el7ost.noarch
...
/usr/share/openstack-tripleo-heat-templates/compat
...
/usr/share/openstack-tripleo-heat-templates/mitaka
...


Additional info:

Comment 3 Dan Yasny 2016-10-17 16:14:52 UTC
verified on openstack-tripleo-heat-templates-compat-2.0.0-34.3.el7ost.noarch

Comment 5 errata-xmlrpc 2016-12-14 16:10:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.