Bug 1382226 - PG scrub bypasses 'osd_scrub_chunk_max' limit to find hash boundary
Summary: PG scrub bypasses 'osd_scrub_chunk_max' limit to find hash boundary
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS
Version: 1.3.3
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: 2.2
Assignee: David Zafman
QA Contact: shylesh
Bara Ancincova
URL:
Whiteboard:
: 1391070 (view as bug list)
Depends On: 1373653 1391070
Blocks: 1412948
TreeView+ depends on / blocked
 
Reported: 2016-10-06 03:38 UTC by Vikhyat Umrao
Modified: 2019-12-16 07:00 UTC (History)
11 users (show)

Fixed In Version: RHEL: ceph-10.2.5-7.el7cp Ubuntu: ceph_10.2.5-3redhat1xenial
Doc Type: Enhancement
Doc Text:
.osd_scrub_chunk_max is honored also with objects that have many clones Previously, deep scrubbing of objects that had a number of clones could impact the client performance. With this enhancement, deep scrubbing honors the limit specified by the `osd_scrub_chunk_max` parameter even when an object has many clones. As a result, the impact on client performance is limited.
Clone Of: 1373653
Environment:
Last Closed: 2017-03-14 15:45:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 17470 None None None 2016-10-06 03:38:36 UTC
Red Hat Product Errata RHBA-2017:0514 normal SHIPPED_LIVE Red Hat Ceph Storage 2.2 bug fix and enhancement update 2017-03-21 07:24:26 UTC

Comment 1 Vikhyat Umrao 2016-11-02 14:05:43 UTC
*** Bug 1391070 has been marked as a duplicate of this bug. ***

Comment 2 Samuel Just 2017-01-04 21:32:33 UTC
16f9d95204f3eca6908ae241e5bacc48b006cb23

Comment 3 Ken Dreyer (Red Hat) 2017-01-17 03:18:10 UTC
Fix landed in v10.2.4 upstream

Comment 13 errata-xmlrpc 2017-03-14 15:45:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0514.html


Note You need to log in before you can comment on or make changes to this bug.