Bug 1382247 - installonlypkgs doesn't work by provides
Summary: installonlypkgs doesn't work by provides
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
high
medium
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
: 1199715 1382246 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-06 06:13 UTC by Igor Gnatenko
Modified: 2016-12-02 15:21 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-02 15:21:15 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Igor Gnatenko 2016-10-06 06:13:55 UTC

Comment 1 Igor Gnatenko 2016-10-06 06:14:55 UTC
default installonlypkgs includes "installonlypkg(kernel)", but packages like kernel-PAE, kernel-lpae and others are still not allowed to be installed multiple time.

Comment 2 Igor Gnatenko 2016-10-06 06:15:58 UTC
*** Bug 1382246 has been marked as a duplicate of this bug. ***

Comment 3 Jaroslav Mracek 2016-10-17 11:26:56 UTC
Fixed by PR: https://github.com/rpm-software-management/dnf/pull/631

Comment 4 Igor Gnatenko 2016-11-21 09:09:23 UTC
*** Bug 1199715 has been marked as a duplicate of this bug. ***

Comment 5 Igor Gnatenko 2016-12-02 15:21:15 UTC
wondering if we have this bug in libdnf..


Note You need to log in before you can comment on or make changes to this bug.