Bug 1382444 - [abrt] xorg-x11-server-Xorg: Segmentation fault in FlushAllOutput
Summary: [abrt] xorg-x11-server-Xorg: Segmentation fault in FlushAllOutput
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ab1fc17b79eaf4910c1c341c90f...
: 1384056 1384561 1389078 1391767 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-06 17:43 UTC by Mikhail
Modified: 2017-03-13 20:12 UTC (History)
16 users (show)

Fixed In Version: xorg-x11-server-1.19.0-0.7.rc2.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-19 21:10:24 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (407 bytes, text/plain)
2016-10-06 17:43 UTC, Mikhail
no flags Details
File: dmesg (146.09 KB, text/plain)
2016-10-06 17:43 UTC, Mikhail
no flags Details
File: dso_list (245 bytes, text/plain)
2016-10-06 17:43 UTC, Mikhail
no flags Details
File: etc_X11_xorg_conf_d.tar.gz (369 bytes, application/octet-stream)
2016-10-06 17:43 UTC, Mikhail
no flags Details
File: usr_share_xorg_conf_d.tar.gz (1.71 KB, application/octet-stream)
2016-10-06 17:43 UTC, Mikhail
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1384508 None None None Never

Internal Links: 1384508

Description Mikhail 2016-10-06 17:43:39 UTC
Version-Release number of selected component:
xorg-x11-server-Xorg-1.19.0-0.1.20160929.fc25

Additional info:
reporter:       libreport-2.8.0
executable:     /usr/libexec/Xorg
kernel:         4.8.0-0.rc8.git0.1.fc25.x86_64+debug
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           xorg
uid:            0

Truncated backtrace:
0: /usr/libexec/Xorg (OsLookupColor+0x139) [0x59df59]
1: /lib64/libpthread.so.0 (__restore_rt+0x0) [0x7fe65768f5bf]
2: /usr/libexec/Xorg (FlushAllOutput+0x63) [0x59d5d3]
3: /usr/libexec/Xorg (SendErrorToClient+0x262) [0x436ed2]
4: /usr/libexec/Xorg (InitFonts+0x428) [0x43afb8]
5: /lib64/libc.so.6 (__libc_start_main+0xf1) [0x7fe6572d8401]
6: /usr/libexec/Xorg (_start+0x2a) [0x424c9a]
7: ? (?+0x2a) [0x2a]

Comment 1 Mikhail 2016-10-06 17:43:42 UTC
Created attachment 1207996 [details]
File: backtrace

Comment 2 Mikhail 2016-10-06 17:43:44 UTC
Created attachment 1207997 [details]
File: dmesg

Comment 3 Mikhail 2016-10-06 17:43:46 UTC
Created attachment 1207998 [details]
File: dso_list

Comment 4 Mikhail 2016-10-06 17:43:47 UTC
Created attachment 1207999 [details]
File: etc_X11_xorg_conf_d.tar.gz

Comment 5 Mikhail 2016-10-06 17:43:49 UTC
Created attachment 1208000 [details]
File: usr_share_xorg_conf_d.tar.gz

Comment 6 František Zatloukal 2016-10-07 02:10:43 UTC
Description of problem:
Random crash during playing War Thunder in Wine (CSMT enabled, Lowest settings). 
War Thunder crashed first, then entire Xserver.

Version-Release number of selected component:
xorg-x11-server-Xorg-1.19.0-0.2.20160929.fc25

Additional info:
reporter:       libreport-2.8.0
executable:     /usr/libexec/Xorg
kernel:         4.8.0-0.rc8.git0.1.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           xorg
uid:            0

Truncated backtrace:
0: /usr/libexec/Xorg (OsLookupColor+0x139) [0x59df59]
1: /lib64/libpthread.so.0 (__restore_rt+0x0) [0x7f4221d985bf]
2: /usr/libexec/Xorg (FlushAllOutput+0x63) [0x59d5d3]
3: /usr/libexec/Xorg (SendErrorToClient+0x30d) [0x436f7d]
4: /usr/libexec/Xorg (InitFonts+0x428) [0x43afb8]
5: /lib64/libc.so.6 (__libc_start_main+0xf1) [0x7f42219e1401]
6: /usr/libexec/Xorg (_start+0x2a) [0x424c9a]
7: ? (?+0x2a) [0x2a]

Comment 7 Gerardo Rosales 2016-10-07 04:58:51 UTC
Description of problem:
Usual workload, edit files with gedit, Files was opened, a terminal (ssh into my local server) window and firefox ( 4 tabs )

The pc became unresponsive then I was kicked out to the login screen.

Version-Release number of selected component:
xorg-x11-server-Xorg-1.19.0-0.2.20160929.fc25

Additional info:
reporter:       libreport-2.8.0
executable:     /usr/libexec/Xorg
kernel:         4.8.0-0.rc8.git0.1.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           xorg
uid:            0

Truncated backtrace:
0: /usr/libexec/Xorg (OsLookupColor+0x139) [0x59df59]
1: /lib64/libpthread.so.0 (__restore_rt+0x0) [0x7f8456ca25bf]
2: /usr/libexec/Xorg (FlushAllOutput+0x63) [0x59d5d3]
3: /usr/libexec/Xorg (SendErrorToClient+0x30d) [0x436f7d]
4: /usr/libexec/Xorg (InitFonts+0x428) [0x43afb8]
5: /lib64/libc.so.6 (__libc_start_main+0xf1) [0x7f84568eb401]
6: /usr/libexec/Xorg (_start+0x2a) [0x424c9a]
7: ? (?+0x2a) [0x2a]

Comment 8 Hans de Goede 2016-10-11 09:05:52 UTC
Hi,

2 questions:

1) How are you starting Xorg (graphical login with GDM, startx, ... ? )
2) Which desktop environment are you using

Regards,

Hans

Comment 9 František Zatloukal 2016-10-11 13:00:07 UTC
1) GDM
2) GNOME

Comment 10 Gerardo Rosales 2016-10-11 20:04:27 UTC
Same here:

1) GDM
2) GNOME

Comment 11 Olivier Fourdan 2016-10-21 11:26:31 UTC
Actually, I reckon the symbols in the backtrace are unlikely to be correct.

Instead "addr2line -fe /usr/lib/debug/usr/libexec/Xorg.debug 0x59d5d3 0x436f7d 0x43afb8" gives:

  FlushAllOutput() in /usr/src/debug/xorg-server-20160929/os/io.c:612
  Dispatch() in /usr/src/debug/xorg-server-20160929/dix/dispatch.c:3491
  dix_main() in /usr/src/debug/xorg-server-20160929/dix/main.c:296

with /usr/src/debug/xorg-server-20160929/os/io.c:612 

 612     xorg_list_for_each_entry_safe(client, tmp, &output_pending_clients, output_pending) {
 613         if (client->clientGone)
 614             continue;
 615         if (!client_is_ready(client)) {
 616             oc = (OsCommPtr) client->osPrivate;
 617             (void) FlushClient(client, oc, (char *) NULL, 0);
 618         } else
 619             NewOutputPending = TRUE;
 620     }

So it could be that output_pending_clients list got corrupted somehow.

Comment 12 Łukasz Faber 2016-10-31 13:36:31 UTC
This is happening to me every few hours on Fedora 25 (GDM, Gnome). And seems to be related to other problems (they happen at the same time according to abrt):

https://bugzilla.redhat.com/show_bug.cgi?id=1384056
https://bugzilla.redhat.com/show_bug.cgi?id=1384508
https://bugzilla.redhat.com/show_bug.cgi?id=1390198

The system is really unusable with this.

Comment 13 Joel Ong 2016-10-31 20:00:26 UTC
This happens for me too. 1384508 was rejected as a blocker today, but if these bugs are related there may be grounds for reconsideration.

Comment 14 Olivier Fourdan 2016-11-02 08:08:44 UTC
GNOME apps in X11 need the Xorg server, if it dies unexpectedly, the apps will die as well.

So I reckon the real issue is this bug, the other crashes that occurs in GNOME at the same time are most likely side effects of this one.

Comment 15 Joel Ong 2016-11-02 12:59:58 UTC
This problem seems to have gone away for me after I changed from SNA to modesetting driver (using Intel graphics), so I'd say the real issue is #1384486.

Comment 16 Łukasz Faber 2016-11-02 13:08:44 UTC
I have Radeon:
05:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Juniper XT [Radeon HD 5770]
And I am using radeon driver, so I don't think it's an SNA issue.

Comment 17 Hans de Goede 2016-11-03 16:12:34 UTC
*** Bug 1384056 has been marked as a duplicate of this bug. ***

Comment 18 Hans de Goede 2016-11-03 16:13:07 UTC
*** Bug 1384561 has been marked as a duplicate of this bug. ***

Comment 19 Hans de Goede 2016-11-03 16:23:13 UTC
*** Bug 1389078 has been marked as a duplicate of this bug. ***

Comment 20 Fedora Update System 2016-11-03 17:22:57 UTC
xorg-x11-server-1.19.0-0.7.rc2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-662f51a695

Comment 21 Hans de Goede 2016-11-04 11:54:39 UTC
*** Bug 1391767 has been marked as a duplicate of this bug. ***

Comment 22 Vlad 2016-11-05 18:43:23 UTC
This happens to me when in MATE but doesn't when in Gnome with wayland.

Comment 23 Fedora Update System 2016-11-05 18:59:14 UTC
xorg-x11-server-1.19.0-0.7.rc2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-662f51a695

Comment 24 Adam Jackson 2016-11-14 17:30:51 UTC
(In reply to Fedora Update System from comment #23)
> xorg-x11-server-1.19.0-0.7.rc2.fc25 has been pushed to the Fedora 25 testing
> repository. If problems still persist, please make note of it in this bug
> report.

Can someone experiencing this issue please test this update and report whether it resolves the problem? This bug is blocking the upstream 1.19 xserver release, so we need to know if this is a fix or if we need to investigate further.

Comment 25 Gerard Ryan 2016-11-14 18:45:33 UTC
(In reply to Adam Jackson from comment #24)
> Can someone experiencing this issue please test this update and report
> whether it resolves the problem? This bug is blocking the upstream 1.19
> xserver release, so we need to know if this is a fix or if we need to
> investigate further.

I've had that update since the day it was released, and I haven't hit this bug since. I'm not sure what I was doing the only time that I previously encountered it, so I don't know how to reproduce it. In any case, I'll leave positive karma in bodhi now

Comment 26 Vlad 2016-11-15 06:27:34 UTC
(In reply to Adam Jackson from comment #24)
> (In reply to Fedora Update System from comment #23)
> > xorg-x11-server-1.19.0-0.7.rc2.fc25 has been pushed to the Fedora 25 testing
> > repository. If problems still persist, please make note of it in this bug
> > report.
> 
> Can someone experiencing this issue please test this update and report
> whether it resolves the problem? This bug is blocking the upstream 1.19
> xserver release, so we need to know if this is a fix or if we need to
> investigate further.

Never happened to me since the update.

Comment 27 Fedora Update System 2016-11-19 21:10:24 UTC
xorg-x11-server-1.19.0-0.7.rc2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.