Bug 1382603 - autofs map resolution doesn't work offline
Summary: autofs map resolution doesn't work offline
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd
Version: 6.9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: SSSD Maintainers
QA Contact: Steeve Goveas
URL:
Whiteboard:
Depends On: 1382602
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-07 07:08 UTC by Jakub Hrozek
Modified: 2020-05-04 10:58 UTC (History)
10 users (show)

Fixed In Version: sssd-1.13.3-42.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1382602
Environment:
Last Closed: 2017-03-21 09:58:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github SSSD sssd issues 4173 None None None 2020-05-04 10:58:28 UTC
Red Hat Product Errata RHBA-2017:0632 normal SHIPPED_LIVE sssd bug fix and enhancement update 2017-03-21 12:30:13 UTC

Description Jakub Hrozek 2016-10-07 07:08:55 UTC
+++ This bug was initially created as a clone of Bug #1382602 +++

This bug is created as a clone of upstream ticket:
https://fedorahosted.org/sssd/ticket/3140

to reproduce the autofs maps failure:
    * automount -m      # to verify the maps are there
    * pkill -USR1 sssd  # make sssd go offline
    * automount -m      # to verify the maps are there

Comment 1 Jakub Hrozek 2016-10-07 07:10:55 UTC
master: b9e155da725e711ab306ca8a96e3ba6fbda41a3a

Comment 6 Niranjan Mallapadi Raghavender 2016-12-15 05:44:50 UTC
Versions:
[root@auto-hv-02 db]# rpm -qa | grep sssd
sssd-ldap-1.13.3-52.el6.x86_64
sssd-krb5-common-1.13.3-52.el6.x86_64
sssd-ad-1.13.3-52.el6.x86_64
sssd-krb5-1.13.3-52.el6.x86_64
sssd-proxy-1.13.3-52.el6.x86_64
sssd-ipa-1.13.3-52.el6.x86_64
sssd-tools-1.13.3-52.el6.x86_64
python-sssdconfig-1.13.3-52.el6.noarch
sssd-common-1.13.3-52.el6.x86_64
sssd-common-pac-1.13.3-52.el6.x86_64
sssd-1.13.3-52.el6.x86_64
sssd-client-1.13.3-52.el6.x86_64


[root@auto-hv-02 db]# 
Red Hat Enterprise Linux Server release 6.9 Beta (Santiago)

automount -m

[root@auto-hv-02 db]# automount -m

autofs dump map information
===========================

global options: none configured

Mount point: /misc

source(s):

  instance type(s): file 
  map: /etc/auto.misc

  cd | -fstype=iso9660,ro,nosuid,nodev  :/dev/cdrom


Mount point: /net

source(s):

  type: hosts

  winsrv1.juno.test | (null)
  auto-hv-02.idmqe.lab.eng.bos.redhat.com | (null)
  localhost | (null)


Mount point: /-

source(s):

  instance type(s): sss 
  map: auto.direct

  /project2 | -fstype=nfs,rw vm-idm-020.lab.eng.pnq.redhat.com:/project2
  /project1 | -fstype=nfs,rw vm-idm-020.lab.eng.pnq.redhat.com:/project1


Mount point: /home

source(s):

  instance type(s): sss 
  map: auto.home

  * | -rw vm-idm-020.lab.eng.pnq.redhat.com:/home/&



[root@auto-hv-02 db]# ps aux | grep sssd
root      2607  0.0  0.0 227824  2692 ?        Ss   11:10   0:00 /usr/sbin/sssd -f -D
root      2608 22.8  1.7 407732 70276 ?        S    11:10   0:32 /usr/libexec/sssd/sssd_be --domain juno.test --uid 0 --gid 0 --debug-to-files
root      2609  0.0  0.7 231092 27952 ?        S    11:10   0:00 /usr/libexec/sssd/sssd_nss --uid 0 --gid 0 --debug-to-files
root      2610  0.0  0.0 210784  3368 ?        S    11:10   0:00 /usr/libexec/sssd/sssd_pam --uid 0 --gid 0 --debug-to-files
root      2611  0.0  0.0 214592  3336 ?        S    11:10   0:00 /usr/libexec/sssd/sssd_autofs --uid 0 --gid 0 --debug-to-files
root      2644  0.0  0.0 103332   844 pts/1    S+   11:13   0:00 grep sssd


Kill sssd process

[root@auto-hv-02 db]#  pkill -USR1 sssd


[root@auto-hv-02 db]# automount -m

autofs dump map information
===========================

global options: none configured

Mount point: /misc

source(s):

  instance type(s): file 
  map: /etc/auto.misc

  cd | -fstype=iso9660,ro,nosuid,nodev  :/dev/cdrom


Mount point: /net

source(s):

  type: hosts

  winsrv1.juno.test | (null)
  auto-hv-02.idmqe.lab.eng.bos.redhat.com | (null)
  localhost | (null)


Mount point: /-

source(s):

  instance type(s): sss 
  map: auto.direct

  /project2 | -fstype=nfs,rw vm-idm-020.lab.eng.pnq.redhat.com:/project2
  /project1 | -fstype=nfs,rw vm-idm-020.lab.eng.pnq.redhat.com:/project1


Mount point: /home

source(s):

  instance type(s): sss 
  map: auto.home

  * | -rw vm-idm-020.lab.eng.pnq.redhat.com:/home/&

Comment 8 errata-xmlrpc 2017-03-21 09:58:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0632.html


Note You need to log in before you can comment on or make changes to this bug.