Bug 138262 - system freezes for minutes at a time when ACPI enabled
Summary: system freezes for minutes at a time when ACPI enabled
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: FCMETA_ACPI
TreeView+ depends on / blocked
 
Reported: 2004-11-06 16:13 UTC by David Juran
Modified: 2015-01-04 22:11 UTC (History)
3 users (show)

Fixed In Version: kernel-smp-2.6.12-1.1398_FC4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-12 17:00:06 UTC
Type: ---


Attachments (Terms of Use)
MagicSysRq log (180.50 KB, text/plain)
2004-11-06 16:14 UTC, David Juran
no flags Details

Description David Juran 2004-11-06 16:13:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
After booting my dual PIII with ACPI enabled, the system kept freezing
for a minute or so at a time. I tried to get a MagicSysRq call trace
while the system was hung but I'm not sure if the trace I got really
was from when the system hung of if it was generated afterwards. The
same moment I hit the key the system started responding again. Also
I'm not sure if it's complete since the system hung before the text
finished scrolling and this time it was dead for good. Anyway, I'm
attaching it here. 
If booting with the option acpi=off there are no problems at all. 

Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-1.667

How reproducible:
Always

Steps to Reproduce:
1. boot without acpi=off

    

Additional info:

Comment 1 David Juran 2004-11-06 16:14:03 UTC
Created attachment 106251 [details]
MagicSysRq log

Comment 2 Len Brown 2004-11-19 04:33:17 UTC
goes away if you boot with "acpi=off"?

If you boot with ACPI enabled, but rmmod thermal
and rmmod processor, does it go away?

Does /proc/interrupts show a bunch of acpi interrupts
after the failure?


Comment 3 David Juran 2004-11-20 11:55:24 UTC
I have no such modules as thermal or processor, I believe the they are
compiled into the kernel. Also I the acpi interrupt count is still 0
after such a failure.

Comment 4 Dave Jones 2005-08-04 19:19:26 UTC
still a problem with the latest kernels ?


Comment 5 David Juran 2005-08-12 17:00:06 UTC
No, I can no longer reproduce this with kernel-smp-2.6.12-1.1398_FC4 (-:


Note You need to log in before you can comment on or make changes to this bug.