Bug 138264 - installing packages required in new default/base installation
installing packages required in new default/base installation
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-06 13:51 EST by Florian Effenberger
Modified: 2014-01-21 17:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-30 01:12:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Effenberger 2004-11-06 13:51:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5)
Gecko/20041104 Firefox/1.0RC2

Description of problem:
I would like to see an option of installing packages required in new
default/base installation.

Example: When you upgrade to the recent yum, a new package
fedora-rawhide-something.rpm has to be installed in order to get the
yum.repos.d directory.

From Core X to Core Y release, some packages are being added to the
package sets as required, because they introduce vital new functionality.

I would like to have these packages when upgrading. Either via an
extra option or via normal depencencies, e.g.
fedora-rawhide-something.rpm should be required by newer yums.

This makes updating much easier.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
xxx
    

Additional info:
Comment 1 Seth Vidal 2004-11-17 10:03:27 EST
why not use groupupdate "Base" "Core"

that should give you new packages in either.
Comment 2 Florian Effenberger 2004-11-17 11:30:12 EST
Hm, do these groups exist?

[root@floeff2 ~]# yum grouplist
Setting up Group Process
Setting up Repo:  base
repomd.xml                100% |=========================| 1.1 kB    00:00
Setting up Repo:  updates-released
repomd.xml                100% |=========================|  951 B    00:00
comps.xml                 100% |=========================| 591 kB    00:00
Installed Groups:
   Compatibility Arch Support
   Mail Server
   Server Configuration Tools
   System Tools
   Text-based Internet
Available Groups:
   Administration Tools
   Authoring and Publishing
   Compatibility Arch Development Support
   DNS Name Server
   Development Tools
   Editors
   Engineering and Scientific
   FTP Server
   GNOME Desktop Environment
   GNOME Software Development
   Games and Entertainment
   Graphical Internet
   Graphics
   KDE (K Desktop Environment)
   KDE Software Development
   Legacy Network Server
   Legacy Software Development
   MySQL Database
   Network Servers
   News Server
   Office/Productivity
   PostgreSQL Database
   Printing Support
   Sound and Video
   Web Server
   Windows File Server
   X Software Development
   X Window System
   XFCE
   XFCE Software Development
   x86 Compatibility Arch Development Support
Done
Comment 3 Seth Vidal 2004-11-17 12:40:51 EST
yum grouplist hidden

they're hidden groups
Comment 4 Florian Effenberger 2004-11-17 13:15:14 EST
Thanks, that sounds good, although it isn't documented. :)
Comment 5 Seth Vidal 2004-11-30 01:08:49 EST
You're right, it's not. If you have the time and would like to write
up a patch to the manpages I'd appreciate it.
Comment 6 Seth Vidal 2004-11-30 01:12:56 EST
I'm going to close this as notabug b/c it technically isn't. Just
poorly documented.

Note You need to log in before you can comment on or make changes to this bug.