This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 138277 - u2date / rewhide python has rolled to 2.4 but some packages are locked to 2.3
u2date / rewhide python has rolled to 2.4 but some packages are locked to 2.3
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-07 02:24 EST by Pete Lancashire
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-29 09:41:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pete Lancashire 2004-11-07 02:24:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040615 Firefox/0.9

Description of problem:
Nov 6, 23:33 - did an up2date and python has rolled to 2.4,
but there are packages that are still looking for 2.3

example alchemist 1.0.34-1 requires python-abi = 2.3

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. have alchemist 1.0.34-1 installed
2. up2date -u

    

Actual Results:  Unresolved chain of dependencies ...

Alchemist-1.0.34-1 requires python-abi = 2.3

Expected Results:  alchemist, gnome-python2, pyparted,
system-config-printer
(at least) need to be rolled or allow for python 2.4

Additional info:

time to go to bed ...
Comment 1 Robert Scheck 2004-11-07 17:54:50 EST
Lots of packages need to be rebuilded against Python 2.4, alternatively
we should get something like at perl for a backward compatibility.
Comment 2 John Thacker 2006-10-29 09:41:02 EST
Note that FC1 and FC2 are no longer supported even by Fedora Legacy, and FC3 and
FC4 are supported by Fedora Legacy only for security issues.  Please retest this
bug against a still supported version and retest.  If this still occurs on FC3
or FC4 and is a security issue, please reopen the bug and assign it to that
version and Fedora Legacy.  If it occurs on RHEL, please change to that product
and the appropriate version.

Note that up2date has been replaced by pirut/pup for FC5 and FC6, the only
fully-supported versions of Fedora Core.  Please test pirut for software updates
and file bugs as appropriate.

Note You need to log in before you can comment on or make changes to this bug.