Bug 1382820 - Xfce is missing some NetworkManager's libs
Summary: Xfce is missing some NetworkManager's libs
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: LiveCD - Xfce
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact:
URL:
Whiteboard: AcceptedFreezeException
Keywords:
Depends On:
Blocks: F25FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2016-10-07 20:08 UTC by Giulio 'juliuxpigface'
Modified: 2018-01-31 22:54 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-23 18:24:23 UTC


Attachments (Terms of Use)

Description Giulio 'juliuxpigface' 2016-10-07 20:08:50 UTC
Description of problem:
Xfce's NetworkManager fails to create some specific connections, because two libraries are missing from the set of packages.

Version-Release number of selected component (if applicable):
Fedora-Xfce-Live-x86_64-25_Beta-1.1.iso

How reproducible:
Always

Steps to Reproduce:
1.Boot Fedora 25 Xfce.
2.Attempt to create a new VPN Connection (openconnect, openvpn or pptp) via NetworkManager

Actual results:
1. A dialog tells that some libraries are missing (libnm-vpn-plugin-openconnect-editor.so and libnm-vpn-plugin-pptp-editor.so)

Expected results:
1. NetworkManager should display its handy wizards as usually.

Additional info:
Installing packages "NetworkManager-openconnect-gnome" and "NetworkManager-pptp-gnome.x86_64 1:1.2.4-1.fc25" solves the issue.

Comment 1 Giulio 'juliuxpigface' 2016-10-07 20:16:25 UTC
The fix seems easy to me, so... I'm proposing this as FE for Fedora 25, because it might be a little violation of the "2.4.7 Default panel functionality" Release Criterion.

"All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use."

However, the key question is...

..."Would this bug cause significant inconvenience or just a really bad first impression to a typical user or reviewer of the release?"

https://fedoraproject.org/wiki/Fedora_25_Final_Release_Criteria#Default_panel_functionality

Comment 2 Kevin Fenzi 2016-10-08 20:23:21 UTC
There's no need for a FE here... Beta is already signed off on, so there won't be any more changes there. I can add this for post beta. 

However, on question: should we install all of those?

NetworkManager-openvpn-gnome.x86_64
NetworkManager-pptp-gnome.x86_64
NetworkManager-vpnc-gnome.x86_64
NetworkManager-fortisslvpn-gnome.x86_64
NetworkManager-iodine-gnome.x86_64
NetworkManager-l2tp-gnome.x86_64
NetworkManager-libreswan-gnome.x86_64
NetworkManager-openconnect-gnome.x86_64
NetworkManager-ssh-gnome.x86_64
NetworkManager-sstp-gnome.x86_64
NetworkManager-strongswan-gnome.x86_64

I'm not sure how much larger that might make things, but I guess we could...

Comment 3 Geoffrey Marr 2016-10-24 18:14:39 UTC
Discussed during the 2016-10-24 blocker review meeting: [1]

The decision to classify this bug as an AcceptedFreezeException was made as this would be good to fix for the Xfce release.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2016-10-24/f25-blocker-review.2016-10-24-16.01.txt

Comment 4 Kevin Fenzi 2016-11-06 21:18:55 UTC
Filed https://pagure.io/fedora-comps/pull-request/65 to fix this issue for Xfce. 

It might be other desktops also have this issue if anyone cares. ;)

Comment 5 Kevin Fenzi 2016-11-14 23:06:12 UTC
PR was merged.

Comment 6 GerardoA 2016-11-23 18:05:22 UTC
I have the same issue using Cinnamon after upgrading from 24 to 25
Can't connect at all or edit any openconnect VPN connections.

Comment 7 Kevin Fenzi 2016-11-23 18:24:23 UTC
Well, I fixed this for Xfce. ;) Cinnamon maintainers will have to do similarly. 

Can you please file a new bug against Cinnamon? 

Thanks.

Comment 8 Daniel Andrei Minca 2018-01-31 22:54:18 UTC
Issue occurs on Fedora 27 LXDE as well.


Note You need to log in before you can comment on or make changes to this bug.