Bug 138284 - Man file cancel-cups is missing, symlinks are there
Summary: Man file cancel-cups is missing, symlinks are there
Status: CLOSED DUPLICATE of bug 136973
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: cups   
(Show other bugs)
Version: 3.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-07 13:39 UTC by Anton Rops
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:06:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Anton Rops 2004-11-07 13:39:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040803 Firefox/0.9.3

Description of problem:
During the standard cron job cron.weekly the script makewhatis is
executed. This generates the error message:

zcat: ./cancel.1.gz: No such file or directory

This also can be reproduces with the command "makewhatis -c".

The file ./cancel.1.gz appears to refer to
usr/share/man/man1/cancel.1.gz which is symlinked to
/etc/alternatives/print-cancelman which is symlinked to
/usr/share/man/man1/cancel-cups.1.gz. This last file is not there.

Version-Release number of selected component (if applicable):
cups-1.1.17-13.3.16

How reproducible:
Always

Steps to Reproduce:
1.Run makewhatis -w
2.
3.
    

Actual Results:  Error:
zcat: ./cancel.1.gz: No such file or directory


Expected Results:  No message

Additional info:

Comment 1 UQ Business School 2004-11-08 00:11:46 UTC
The problem is caused after updating from cups-1.1.17-13.3.13.i386.rpm
to  cups-1.1.17-13.3.16.i386.rpm.

The new RPM does not include the /usr/share/man/man1/cancel-cups.1.gz
 file.  The old one did.

As such, you should be able to work around the problem by either
. extracting the file from the old RPM, (I'd love an  rpm2tar command
- rpm2cpio is annoying - cpio is just painful)    or

. just copying some other manual in its place, which will make 
makewhatis stop whining.  you could use the french manual, which for
some strange reason is included in the cups RPM. along with french
templates etc..  (why!?)

cheers
/\ndy

Comment 2 Tim Waugh 2004-11-08 16:42:01 UTC
This is a duplicate of bug #136973.

Comment 3 Tim Waugh 2004-11-15 11:25:39 UTC

*** This bug has been marked as a duplicate of 136973 ***

Comment 4 Red Hat Bugzilla 2006-02-21 19:06:48 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.