Bug 1382880 - selinux-policy package scripts complaints "user system_u not in password file"
Summary: selinux-policy package scripts complaints "user system_u not in password file"
Keywords:
Status: CLOSED DUPLICATE of bug 1378204
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-08 02:07 UTC by Michal Jaegermann
Modified: 2016-10-10 10:21 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-10 10:21:17 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2016-10-08 02:07:50 UTC
Description of problem:

While updating selinux-policy-targeted package the following shows up:

libsemanage.add_user: user system_u not in password file

A check of the package scripts reveals that that message is a result of running:

   /usr/sbin/semodule -B -n -s targeted;

User 'system_u' is indeed absent from /etc/passwd.  Should be there?

Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-218.fc26

Additional info:
On this test system selinux is actually disabled.

Comment 1 Petr Lautrbach 2016-10-10 10:21:17 UTC

*** This bug has been marked as a duplicate of bug 1378204 ***


Note You need to log in before you can comment on or make changes to this bug.