Bug 1382897 - The register button is still enabled when has been registered
Summary: The register button is still enabled when has been registered
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.3
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Kevin Howell
QA Contact: Jan Stavel
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-08 07:06 UTC by Wei Liu
Modified: 2017-08-01 19:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:20:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
The screenshot of the Register button after register (199.76 KB, image/png)
2016-10-08 07:09 UTC, Wei Liu
no flags Details
The rhsm.log (14.45 KB, text/plain)
2016-10-08 07:10 UTC, Wei Liu
no flags Details


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1506 None None None 2016-10-10 20:02:25 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description Wei Liu 2016-10-08 07:06:57 UTC
Description of problem:
Try to register via GUI:system->register,the system->register button is still enabled after register

Version-Release number of selected component (if applicable):
python-rhsm-1.17.9-1.el7.x86_64
python-rhsm-certificates-1.17.9-1.el7.x86_64
subscription-manager-1.17.15-1.el7.x86_64
subscription-manager-gui-1.17.15-1.el7.x86_64
subscription-manager-initial-setup-addon-1.17.15-1.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.Install RHEL-7.3-20161005.0
2.Launch subscription-manager-gui,click system->register button,input valid url address in the blank(subscription.rhsm.stage.redhat.com:443/subscription),then click Next
3.Input account and password (new_test:redhat),then click Register button and Attach subscription
4.After register successfully,go back GUI to check system->register button,is still enabled
5.close the GUI window and launch subscription-manager-gui again.The system->register button become disabled.

Actual results:
The Register button is still enabled after register 

Expected results:
The Register button should be disabled after register

Additional info:

Comment 1 Wei Liu 2016-10-08 07:09:50 UTC
Created attachment 1208292 [details]
The screenshot of the Register button after register

Comment 2 Wei Liu 2016-10-08 07:10:31 UTC
Created attachment 1208293 [details]
The rhsm.log

Comment 4 Wei Liu 2017-03-14 02:53:05 UTC
verify this issue when the RHEL7.4 composes start rolling out

Comment 5 Wei Liu 2017-04-01 08:03:29 UTC
Verifying version:
[root@dhcp-128-6 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.4-1.el7
python-rhsm: 1.19.2-1.el7


Verification:
1.Install build RHEL-7.4-20170330.1,and open Subscription Manager GUI.
2.Register the system by clicking system->register button,then input valid account and password to register
3.After register successfully,go back GUI to check system->register button
the system-> register button become disabled.

So this issue is verified and move the status to "verified".

Comment 6 errata-xmlrpc 2017-08-01 19:20:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.