Bug 138293 - system-config-network not noticing wifi devices, think's they're wired, no way to set WEP keys
system-config-network not noticing wifi devices, think's they're wired, no wa...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
bzcl34nup
:
Depends On:
Blocks: 87718
  Show dependency treegraph
 
Reported: 2004-11-07 12:28 EST by W. S. Yerazunis
Modified: 2008-04-03 14:01 EDT (History)
2 users (show)

See Also:
Fixed In Version: FC8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 14:01:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. S. Yerazunis 2004-11-07 12:28:37 EST
Description of problem:

system-config-network does not correctly pick up wireless
devices, and does not have the ability to set WiFi encoding 
setup and keys.

This _did_ work on FC3test2... and the same version of
system-config-network.  Which means that the problem is happening
earlier than system-config-network and only manifesting 
itself when system-config-network is run.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Clean install of FC3test3
2.  Open system-config-network
3.  Try to config a WiFi device!
  
Actual results:

There is no ability to set WiFi encoding

Expected results:

There should be a way to set WiFi encoding

Additional info:

Worked under FC3test2.
Comment 1 Harald Hoyer 2004-11-08 05:47:28 EST
you may add:
TYPE="Wireless"
to /etc/sysconfig/network-scripts/ifcfg-<wifi device name>

and retry.
Comment 2 W. S. Yerazunis 2004-11-08 10:00:10 EST
Adding 

  TYPE=Wireless

to the ifcfg for the device worked.  I can now configure WiFi
appropriately.

So, the bug now is "why didn't the network setup wizard correctly
assign the WiFi device as "Wireless", rather than as "Ethernet"?

Comment 3 Matthew Miller 2006-07-10 16:32:53 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 4 Bug Zapper 2008-04-03 11:45:00 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 5 W. S. Yerazunis 2008-04-03 14:01:59 EDT
I think we can close the bug out.

Thanks much.

Since this works fine in the current FC, I will set this bug 
to "CURRENTRELEASE" and closed.

  - Bill Yerazunis

Note You need to log in before you can comment on or make changes to this bug.