Bug 138294 - Battery Monitor 2.8.0 doesn't "see" changes in AC adapter state
Battery Monitor 2.8.0 doesn't "see" changes in AC adapter state
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-07 12:39 EST by W. S. Yerazunis
Modified: 2008-08-02 19:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 11:44:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. S. Yerazunis 2004-11-07 12:39:35 EST
Description of problem:

Battery monitor v. 2.8.0 doesn't see changes in AC adapter state.
This worked in FC3Test2, doesn't work in FC3test3

Version-Release number of selected component (if applicable):


How reproducible:

Plug laptop AC adapter in, remove adapter.  

Steps to Reproduce:
1. clean install of FC3test3 (format disk, install everything)
2. put battery monitor applet into task bar.
3. plug in and remove ac adapter.  Although
/proc/acpi/ac_adatper/AC/state shows changes, the battery monitor
image does NOT.
  
Actual results:

No change in icons.  Whatever the system had for power on bootup
stays.

Expected results:

It should show on battery or on AC.  It used to, in FC3test2
Additional info:
Comment 1 Bill Nottingham 2004-11-08 00:05:51 EST
This works fine for me. What events are you getting on plug/unplug?
Comment 2 W. S. Yerazunis 2004-11-08 09:49:59 EST
I just tested it by running acpi_listen.

I get no events at all with AC adapter jack/unjack.

I do get battery install events, but not battery remove events.

I do get lid-switch events (both lid down, and lid up).  It doesn't
say which _way_ the lid went, though.

This is on a Fujitsu P2120 laptop with ACPI.
Comment 3 Bill Nottingham 2004-11-08 11:58:10 EST
$ acpi_listen
ac_adapter AC 00000080 00000000
battery BAT0 00000080 00000001
battery BAT0 00000080 00000001
ac_adapter AC 00000080 00000001
battery BAT0 00000080 00000001
battery BAT0 00000080 00000001

I'm getting the events. Assigning to kernel, looks like kernel/bios
interactions.
Comment 4 Richard A. Stout 2004-11-10 00:58:57 EST
This problem has carried into FC3 final. I get this problem as well,
but when I remove the power cord, I get battery install events

battery BAT0 00000080 00000001

as well as some cpu throttling events. Putting the cord back gives me
the same event. Interesting thing to note: If I remove the widget from
the panel (right-click, remove from panel) then add it back to the
panel, the widget shows the correct state (AC or Battery). /proc AC
state shows the proper status. 
Comment 5 Russell Tokuyama 2004-12-18 16:50:47 EST
I've noticed the same problem with FC2 (I'm currently at
2.6.9-1.9_FC2/i686) on an IBM ThinkPad A22p laptop.  The battery
events are being logged to /var/log/acpid and indicate that the
battery monitor applet is being notified (notifying client
3141[1000:500]; 3141 is the pid of /usr/libexec/battstat-applet-2).
Comment 6 Jeff Orcutt 2005-06-14 15:17:28 EDT
This happens to me too with FC4 (2.10.1)

here's my acpi_listen output

*unplug*
battery BAT1 00000080 00000001
processor CPU0 00000080 00000001
*plug*
battery BAT1 00000080 00000001
processor CPU0 00000080 00000000
battery BAT1 00000081 00000001
battery BAT1 00000080 00000001

cat /proc/acpi/ac_adapter/ACAD/state returns the correct value (on-line/off-line) 
as does cat /proc/acpi/battery/BAT1/state


I have a compaq R3000 laptop

This feature worked correctly for me on Ubuntu 5.04


Comment 7 Dave Jones 2005-07-15 16:26:07 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 8 Jeff Orcutt 2005-07-16 19:52:17 EDT
Still occurs for me on FC4, kernel 2.6.12-1.1398_FC4

and i tried to change the version field but could not
Comment 9 Dave Jones 2005-07-29 20:27:38 EDT
Ok, I've seen this happen myself too now. As the kernel is reporting the right
things to userspace, this must be a bug in the gnome-applet not realising the
state change.

I've seen it do really bizarre things, where the state is inverted and thinks
its on battery, and survives at 0% for hours (basically until I turn it off).
Comment 10 Matthew Miller 2006-07-10 17:37:20 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 11 Ray Strode [halfline] 2007-08-14 11:44:46 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there haven't been any
updates to the report in quite a long time now after we've
requested additional information, we're assuming the problem
is either no longer present in our current OS release, or
that there is no longer any interest in tracking the problem.

Setting status to CANTFIX, however if you still
experience this problem after updating to our latest Fedora
Core release and are still interested in Red Hat tracking
the issue, and assisting in troubleshooting the problem,
please feel free to provide the information requested above,
and reopen the report.

Thank you in advance.

(this message is mass message)

Note You need to log in before you can comment on or make changes to this bug.