Bug 1382956 - Fail to upload images with Glance
Summary: Fail to upload images with Glance
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: rc
: 10.0 (Newton)
Assignee: Ben Nemec
QA Contact: Arik Chernetsky
URL:
Whiteboard:
: 1383030 1383403 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-08 18:01 UTC by Arie Bregman
Modified: 2016-12-14 16:14 UTC (History)
16 users (show)

Fixed In Version: python-tripleoclient-5.2.0-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:14:16 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 382656 None None None 2016-10-10 20:14:07 UTC
OpenStack gerrit 382658 None None None 2016-10-10 20:14:32 UTC
Launchpad 1630743 None None None 2016-10-10 20:15:32 UTC

Description Arie Bregman 2016-10-08 18:01:11 UTC
Description of problem:

Running 'openstack overcloud image upload', I get the following error: "No schema supplied. Perhaps you meant http://x/v1/images/detail?limit=20?"

Version-Release number of selected component (if applicable):
openstack-glance-13.0.0-1.el7ost.noarch
python-glance-13.0.0-1.el7ost.noarch
python-glance-store-0.18.1-0.20160920174118.4e144bb.el7ost.noarch
python-glanceclient-2.5.0-1.el7ost.noarch

How reproducible: 100%


Steps to Reproduce:
1. Upload overcloud images with 'openstack overcloud image upload'

Actual results: "No schema supplied. Perhaps you meant http://x/v1/images/detail?limit=20?"


Expected results: Images uploaded successfully


Additional info: Link to the CI job which identified the issue, provided in the next comment.

Comment 5 Paul Grist 2016-10-10 18:18:47 UTC
Changing this to post and the component with the fix, please update if that's not correct and thanks for adding the fix info.

Comment 7 Alfredo Moralejo 2016-10-10 19:49:21 UTC
(In reply to Paul Grist from comment #5)
> Changing this to post and the component with the fix, please update if
> that's not correct and thanks for adding the fix info.

looks good to me.

Comment 8 James Slagle 2016-10-10 20:16:38 UTC
*** Bug 1383030 has been marked as a duplicate of this bug. ***

Comment 9 James Slagle 2016-10-11 13:47:09 UTC
*** Bug 1383403 has been marked as a duplicate of this bug. ***

Comment 10 James Slagle 2016-10-11 13:49:04 UTC
*** Bug 1383403 has been marked as a duplicate of this bug. ***

Comment 12 Ben Nemec 2016-12-13 19:05:23 UTC
Regression fixed before release.  No need for doctext.

Comment 14 errata-xmlrpc 2016-12-14 16:14:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.