Bug 138302 - LDAP Rename fails to update modifyTimestamp
LDAP Rename fails to update modifyTimestamp
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openldap (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Safranek
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-07 16:11 EST by Roland Pope
Modified: 2015-01-07 19:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:14:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roland Pope 2004-11-07 16:11:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
When renaming an LDAP entry, the system maintained 'modifyTimestamp' 
attribute remains unchanged. According to a response from an openldap 
mailing-list, this doesn't happen in Openldap-2.2.17, but due to the 
Berkley DB dependancies, I can't get the 2.2.17 version compiled to 
check this. 

Version-Release number of selected component (if applicable):
openldap-2.0.27-17

How reproducible:
Always

Steps to Reproduce:
1. create a non-leaf entry in an OpenLDAP database
2. Rename the entry
3. confirm that the modifyTimestamp remains unchanged
    

Actual Results:  The modifyTimestamp remains unchanged on a rename


Expected Results:  Renaming an entry invoves at the very least, 
changing it's DN and RDN which should result in the modifyTimestamp 
being updated

Additional info:
Comment 1 RHEL Product and Program Management 2007-10-19 15:14:45 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.