Bug 138309 - (XIM) httx activation inconsistent with IIIMF
Summary: (XIM) httx activation inconsistent with IIIMF
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: iiimf   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact:
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: IIIMF FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2004-11-08 02:35 UTC by Warren Togami
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-20 09:35:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Warren Togami 2004-11-08 02:35:28 UTC
Description of problem:
httx activation hotkey works with CTRL-SPACE but not SHIFT-SPACE. 
This is bad because it is inconsistent with native IIIMF input.  Also
Japanese and Korean legacy users know and prefer SHIFT-SPACE while
disliking CTRL-SPACE.

Version-Release number of selected component (if applicable):
im-sdk-12.1-6

Comment 1 Akira TAGOH 2005-02-18 06:08:16 UTC
Well, I think what you are saying is 1) shift+space which is used on legacy XIM
doesn't work on IIIMF. 2) and should disable ctrl+space on some lanauges.

Well, for 1) it should be fixed in the latest. so we can close it. for 2) it's
the duplicated bug of Bug#118023. for 1) please confirm if it was fixed for you.

Comment 2 Akira TAGOH 2005-03-31 07:02:30 UTC
Ok, well XIM server iiimx doesn't support the hotkey protocol actually. so it's
why iiimgcf works but iiimxcf doesn't. it needs to be implemented. FYI

Comment 3 Akira TAGOH 2005-05-09 09:32:43 UTC
I just considered to separate a bug for 1) and 2). and Bug#157197 was filed to
support the hotkey protocol.

Comment 4 Akira TAGOH 2005-05-10 03:17:11 UTC
Fixed in 12.2-3. now shift+space works with even XIM.


Note You need to log in before you can comment on or make changes to this bug.