Bug 138314 - Generic LCD 1920x1200 allows resolution 1920x1440 not 1920x1200
Summary: Generic LCD 1920x1200 allows resolution 1920x1440 not 1920x1200
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-display   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-08 05:03 UTC by Frederick Dean
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-24 18:28:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log with defaults (48.95 KB, text/plain)
2006-03-03 17:18 UTC, John P. Linderman
no flags Details

Description Frederick Dean 2004-11-08 05:03:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
I am actually using Fedora Core 3 release candidate
of Oct 29th, 2004.

After an install, at the beginning of first boot,
in Anaconda I choose "Generic LCD 1920x1200" but the
resolutions choices end with 1920x1440 not 1920x1200
which is missing.  The xorg.conf file gets written with 
1920x1440, which does not work so it falls back to 1600x1200
and the display appears streched.

I had to manually edit /etc/X11/xorg.conf and
restart the X display with ctrl-alt-backspace.


Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12 

How reproducible:
Always

Steps to Reproduce:
1.  Install Fedora Core 3 release candidate of Oct 29 on
    Dell Inspiron Laptop with 1920x1200 screen with 
    ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]
2.  On first boot change moditor to Generic LCD 1920x1200
3.  Have 1920x1200 not listed as available resolutionbut
    1920x1440 is listed.
4.  Choose 1920x1440

    

Actual Results:   Box boots into 1600x1200 resolution.

Expected Results:  Running in 1920x1200 resolution would be nice.

Additional info:

Comment 1 Gordon Hopper 2004-12-20 23:37:07 UTC
I have duplicated this issue on my Dell Precision m60, using the
released version of FC3.  "Generic LCD 1920x1200" does not enable any
of the wide aspect modes.  Note that the other wide-aspect LCD panels
("1680x1050", "1440x900", and "1280x800") do not enable the wide
aspect modes.  However, all 4 of these wide-aspect LCD panels enable
all the 3:4 modes including 1920x1440, which is interesting because
that's bigger than any of the LCD displays.

Comment 2 John P. Linderman 2005-06-29 14:42:34 UTC
I saw something very similar under Fedore Core 4, with my Syncmaster 240T.
The xorg.conf listed 1920x1200 first, but the Xorg.0.log indicated that it
(among many others) had been rejected:

  (WW) (1920x1200,Monitor0) mode clock 228.02MHz exceeds DDC maximum 200MHz

  (II) NV(0): Not using default mode "1920x1200" (hsync out of range)

Oddly, it then defaulted to 1920x1440, which was also rejected, and which
appeared second in the xorg.conf:

  (--) NV(0): Virtual size is 1920x1440 (pitch 1920)

This resulted in a virtual screen larger than the actual screen, so that
whenever I hit the bottom of the screen with my cursor, it "slid the
screen down".  Cycling through the screen sizes with CTRL-ALT-+ never
appeared to reach the 1900x1200 configuration.  I "fixed" the problem
by eliminating all the sizes BUT 1900x1200 from the xorg.conf.  There
are still complaints in the Xorg.0.log, but the 1900x1200 screen size
is used, and the cursor now stops without sliding the screen around.
I saved the Xorg.0.log, in case it might be useful in diagnosing the
real problem(s).

Comment 3 Adam Jackson 2006-03-03 15:53:24 UTC
Please attach an Xorg.0.log from an affected system so the root cause can be
diagnosed.

Comment 4 John P. Linderman 2006-03-03 17:18:08 UTC
Created attachment 125600 [details]
Xorg.0.log with defaults

Comment 5 Adam Jackson 2006-03-22 15:51:34 UTC
okay, so there's two bugs here.  one is we don't have an entry in the built in
mode list for 1920x1200, and the other is the driver doesn't automatically
inject one.

Comment 6 Adam Jackson 2006-08-19 01:45:56 UTC
This should be working automatically as of xorg-x11-server 1.1.1-24.fc6.  Can
you test?

Comment 7 Adam Jackson 2006-09-20 21:36:12 UTC
Reporter, please test with FC6 test3 or later so we can verify that this issue
is resolved.

Comment 8 Frederick Dean 2006-09-21 01:47:34 UTC
My apologies for not posting sooner.  I did not see my
original problem when installing FC5, but don't 
remember seeing the same screen.

I will download FC6 test3, and try again.

Comment 9 Frederick Dean 2006-09-24 18:28:54 UTC
Just installed FC6 test 3 and it came up with the right 
resolution without any adjustment by me.   Excellent.


Note You need to log in before you can comment on or make changes to this bug.