Bug 1383180 - On an SSL enabled overcloud the AODH api returns http URL
Summary: On an SSL enabled overcloud the AODH api returns http URL
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-aodh
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: 10.0 (Newton)
Assignee: Juan Antonio Osorio
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
Depends On:
Blocks: 1384328
TreeView+ depends on / blocked
 
Reported: 2016-10-10 06:20 UTC by Marius Cornea
Modified: 2016-12-14 16:14 UTC (History)
12 users (show)

Fixed In Version: openstack-aodh-3.0.1-4.el7ost puppet-tripleo-5.4.0-3.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1384328 (view as bug list)
Environment:
Last Closed: 2016-12-14 16:14:23 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 384305 None None None 2016-10-10 06:50:12 UTC
OpenStack gerrit 385767 None None None 2016-10-13 06:18:33 UTC
OpenStack gerrit 400591 None None None 2016-11-22 10:27:51 UTC
Launchpad 1590608 None None None 2016-10-10 06:22:19 UTC

Description Marius Cornea 2016-10-10 06:20:07 UTC
Description of problem:
On an SSL enabled overcloud the AODH api returns http URL:

[stack@undercloud-0 ~]$ openstack catalog show aodh
+-----------+-----------------------------------------+
| Field     | Value                                   |
+-----------+-----------------------------------------+
| endpoints | regionOne                               |
|           |   publicURL: https://172.16.18.25:13042 |
|           |   internalURL: http://10.0.0.5:8042     |
|           |   adminURL: http://10.0.0.5:8042        |
|           |                                         |
| name      | aodh                                    |
| type      | alarming                                |
+-----------+-----------------------------------------+

[stack@undercloud-0 ~]$ curl -s -H "X-Auth-Token: $OS_TOKEN" https://172.16.18.25:13042  | python -m json.tool
{
    "versions": {
        "values": [
            {
                "id": "v2",
                "links": [
                    {
                        "href": "http://172.16.18.25:13042/v2",
                        "rel": "self"
                    },
                    {
                        "href": "http://docs.openstack.org/",
                        "rel": "describedby",
                        "type": "text/html"
                    }
                ],
                "media-types": [
                    {
                        "base": "application/json",
                        "type": "application/vnd.openstack.telemetry-v2+json"
                    },
                    {
                        "base": "application/xml",
                        "type": "application/vnd.openstack.telemetry-v2+xml"
                    }
                ],
                "status": "stable",
                "updated": "2013-02-13T00:00:00Z"
            }
        ]
    }
}


Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-5.0.0-0.20160929150845.4cdc4fc.el7ost.noarch
openstack-aodh-api-3.0.0-0.20160921151816.bb5103e.el7ost.noarch

How reproducible:
100%

Comment 2 Nathan Kinder 2016-10-12 21:41:08 UTC
The fix for this has merged upstream in master, but is still needed for stable/newton.

Comment 3 Juan Antonio Osorio 2016-10-13 06:18:54 UTC
backported it to stable/newton upstream

Comment 4 Nathan Kinder 2016-10-20 21:52:31 UTC
The fixes for this have merged upstream for both master and stable/newton.

Comment 8 Rob Crittenden 2016-11-14 19:31:22 UTC
No changes to this component are required. This is being blocked by BZ 1370018 which is fixed upstream and should be in a build soon.

Comment 9 Mehdi ABAAKOUK 2016-11-22 10:25:54 UTC
Upstream https://review.openstack.org/#/c/400591/ should fix the issue

Comment 10 Mehdi ABAAKOUK 2016-11-22 10:26:30 UTC
Oups wrong BZ, ignore my last comment

Comment 15 Yurii Prokulevych 2016-12-02 14:00:15 UTC
openstack catalog show aodh
+-----------+------------------------------------------------------------+
| Field     | Value                                                      |
+-----------+------------------------------------------------------------+
| endpoints | regionOne                                                  |
|           |   publicURL: https://[2620:52:0:13b8:5054:ff:fe3e:1]:13042 |
|           |   internalURL: http://[fd00:fd00:fd00:2000::18]:8042       |
|           |   adminURL: http://[fd00:fd00:fd00:2000::18]:8042          |
|           |                                                            |
| name      | aodh                                                       |
| type      | alarming                                                   |
+-----------+------------------------------------------------------------+

curl -s -XGET -H 'X-Auth-Token: 0aba049b59e84ef1861324a1dfd75024' -g https://[2620:52:0:13b8:5054:ff:fe3e:1]:13042/ | python -m json.tool
{
    "versions": {
        "values": [
            {
                "id": "v2",
                "links": [
                    {
                        "href": "https://[2620:52:0:13b8:5054:ff:fe3e:1]:13042/v2",
                        "rel": "self"
                    },
                    {
                        "href": "http://docs.openstack.org/",
                        "rel": "describedby",
                        "type": "text/html"
                    }
                ],
                "media-types": [
                    {
                        "base": "application/json",
                        "type": "application/vnd.openstack.telemetry-v2+json"
                    },
                    {
                        "base": "application/xml",
                        "type": "application/vnd.openstack.telemetry-v2+xml"
                    }
                ],
                "status": "stable",
                "updated": "2013-02-13T00:00:00Z"
            }
        ]
    }
}

Packages:
puppet-tripleo-5.4.0-3.el7ost.noarch
openstack-aodh-common-3.0.1-4.el7ost.noarch

Comment 17 errata-xmlrpc 2016-12-14 16:14:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.