Bug 1383185 - On an SSL enabled overcloud the heat-cfn api returns http URL
Summary: On an SSL enabled overcloud the heat-cfn api returns http URL
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 10.0 (Newton)
Assignee: Juan Antonio Osorio
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-10 06:31 UTC by Marius Cornea
Modified: 2016-12-14 16:14 UTC (History)
12 users (show)

Fixed In Version: openstack-heat-7.0.0-4.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:14:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 384314 None None None 2016-10-10 06:51:49 UTC
OpenStack gerrit 385766 None None None 2016-10-13 06:22:14 UTC
Launchpad 1590608 None None None 2016-10-10 06:31:49 UTC

Description Marius Cornea 2016-10-10 06:31:49 UTC
Description of problem:
On an SSL enabled overcloud the heat-cfn api returns http URL:

openstack catalog show heat-cfn
+-----------+--------------------------------------------+
| Field     | Value                                      |
+-----------+--------------------------------------------+
| endpoints | RegionOne                                  |
|           |   publicURL: https://172.16.18.25:13005/v1 |
|           |   internalURL: http://10.0.0.5:8000/v1     |
|           |   adminURL: http://10.0.0.5:8000/v1        |
|           |                                            |
| name      | heat-cfn                                   |
| type      | cloudformation                             |
+-----------+--------------------------------------------+

curl -s -H "X-Auth-Token: $OS_TOKEN" https://172.16.18.25:13005/ | python -m json.tool
{
    "versions": [
        {
            "id": "v1.0",
            "links": [
                {
                    "href": "http://172.16.18.25:13005/v1/",
                    "rel": "self"
                }
            ],
            "status": "CURRENT"
        }
    ]
}


Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-5.0.0-0.20160929150845.4cdc4fc.el7ost.noarch
openstack-heat-api-cfn-7.0.0-0.20160926200847.dd707bc.el7ost.noarch

How reproducible:
100%

Comment 2 Nathan Kinder 2016-10-12 21:08:41 UTC
This is related to bug#1370018, which is a higher-level bug that spans multiple components that are having this problem.

The upstream fix for this has merged into master already.

Juan - does this need to be proposed for stable/newton so it can get pulled into OSP10?

Comment 3 Juan Antonio Osorio 2016-10-13 06:22:15 UTC
backported it to stable/newton

Comment 6 Amit Ugol 2016-11-08 18:43:11 UTC
now looks something like this:
{"versions": [{"status": "CURRENT", "id": "v1.0", "links": [{"href": "https://[2620:52:0:13b8:5054:ff:fe3e:1]:13005/v1/", "rel": "self"}]}]}

Comment 8 errata-xmlrpc 2016-12-14 16:14:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.