Bug 1383186 - On an SSL enabled overcloud the Gnocchi api returns http URL
Summary: On an SSL enabled overcloud the Gnocchi api returns http URL
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-gnocchi
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: 10.0 (Newton)
Assignee: Juan Antonio Osorio
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
Depends On:
Blocks: 1384331
TreeView+ depends on / blocked
 
Reported: 2016-10-10 06:34 UTC by Marius Cornea
Modified: 2016-12-14 16:14 UTC (History)
10 users (show)

Fixed In Version: puppet-tripleo-5.4.0-3.el7ost openstack-gnocchi-3.0.1-1.1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1384331 (view as bug list)
Environment:
Last Closed: 2016-12-14 16:14:58 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 384301 None None None 2016-10-10 06:52:56 UTC
OpenStack gerrit 385770 None None None 2016-10-13 06:21:03 UTC
OpenStack gerrit 400686 None None None 2016-11-28 05:04:08 UTC
Launchpad 1590608 None None None 2016-10-10 06:34:18 UTC

Description Marius Cornea 2016-10-10 06:34:19 UTC
Description of problem:
openstack catalog show gnocchi
+-----------+-----------------------------------------+
| Field     | Value                                   |
+-----------+-----------------------------------------+
| endpoints | regionOne                               |
|           |   publicURL: https://172.16.18.25:13041 |
|           |   internalURL: http://10.0.0.5:8041     |
|           |   adminURL: http://10.0.0.5:8041        |
|           |                                         |
| name      | gnocchi                                 |
| type      | metric                                  |
+-----------+-----------------------------------------+

curl -s -H "X-Auth-Token: $OS_TOKEN" https://172.16.18.25:13041/ | python -m json.tool
{
    "versions": [
        {
            "id": "v1.0",
            "links": [
                {
                    "href": "http://172.16.18.25:13041/v1/",
                    "rel": "self"
                }
            ],
            "status": "CURRENT",
            "updated": "2015-03-19"
        }
    ]
}


Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-5.0.0-0.20160929150845.4cdc4fc.el7ost.noarch
openstack-gnocchi-api-3.0.1-0.20160923180636.c6b2c51.el7ost.noarch

How reproducible:
100%

Comment 4 Juan Antonio Osorio 2016-10-13 06:21:04 UTC
backported it to the equivalent of stable/newton, which is stable/3.0

Comment 5 Nathan Kinder 2016-10-20 21:55:26 UTC
This has merged upstream into both master and stable/3.0.

Comment 9 Rob Crittenden 2016-11-14 19:31:16 UTC
No changes to this component are required. This is being blocked by BZ 1370018 which is fixed upstream and should be in a build soon.

Comment 14 Yurii Prokulevych 2016-12-02 13:54:25 UTC
openstack catalog show gnocchi
+-----------+------------------------------------------------------------+
| Field     | Value                                                      |
+-----------+------------------------------------------------------------+
| endpoints | regionOne                                                  |
|           |   publicURL: https://[2620:52:0:13b8:5054:ff:fe3e:1]:13041 |
|           |   internalURL: http://[fd00:fd00:fd00:2000::18]:8041       |
|           |   adminURL: http://[fd00:fd00:fd00:2000::18]:8041          |
|           |                                                            |
| name      | gnocchi                                                    |
| type      | metric                                                     |
+-----------+------------------------------------------------------------+

 curl -s -XGET -H 'X-Auth-Token: 0aba049b59e84ef1861324a1dfd75024' -g https://[2620:52:0:13b8:5054:ff:fe3e:1]:13041/ | python -m json.tool
{
    "versions": [
        {
            "id": "v1.0",
            "links": [
                {
                    "href": "https://[2620:52:0:13b8:5054:ff:fe3e:1]:13041/v1/",
                    "rel": "self"
                }
            ],
            "status": "CURRENT",
            "updated": "2015-03-19"
        }
    ]
}

Packages:
puppet-tripleo-5.4.0-3.el7ost.noarch
openstack-gnocchi-common-3.0.2-1.el7ost.noarch

Comment 16 errata-xmlrpc 2016-12-14 16:14:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.