Bug 1383219 - Unresolved dependency in munin-cgi and reference to nginx user in systemd service file
Summary: Unresolved dependency in munin-cgi and reference to nginx user in systemd ser...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: munin
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: d. johnson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-10 08:44 UTC by Gabriele Pohl
Modified: 2016-12-27 17:17 UTC (History)
4 users (show)

Fixed In Version: munin-2.0.28-2.fc25 munin-2.0.28-2.fc24 munin-2.0.28-2.el6 munin-2.0.28-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-22 05:23:35 UTC


Attachments (Terms of Use)

Description Gabriele Pohl 2016-10-10 08:44:45 UTC
Description of problem:

Start of munin-fcgi-graph.service fails

1. Unresolved dependency

Oct 09 23:19:10 <hostname> systemd[3858]: munin-fcgi-graph.service: Failed at step EXEC spawning /usr/bin/spawn-fcgi: No such file or directory

The missing file is included in package spawn-fcgi

# rpm -qf /usr/bin/spawn-fcgi
spawn-fcgi-1.6.3-10.fc24.x86_64

2. Service script refers to nginx user

# cat /usr/lib/systemd/system/munin-fcgi-graph.service 
...
ExecStart=/usr/bin/spawn-fcgi -s /run/munin/fcgi-graph.sock -U nginx -u munin -g munin /var/www/cgi-bin/munin-cgi-graph -P /run/munin/fcgi-graph.pid

Version-Release number of selected component (if applicable):

munin-cgi-2.0.26-1.fc24.noarch

How reproducible:


Steps to Reproduce:
1. dnf install munin munin-cgi
2. service munin-fcgi-graph start
3. service munin-fcgi-graph status; journalctl -xe

Actual results:

Service fails to start

Expected results:

Service sucessfully started

Additional info:

1. /usr/bin/spawn-fcgi

Oct 10 01:04:43 <hostname> systemd[1]: Starting Munin FastCGI Graph...
-- Subject: Unit munin-fcgi-graph.service has begun start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit munin-fcgi-graph.service has begun starting up.
Oct 10 01:04:43 <hostname> systemd[16429]: munin-fcgi-graph.service: Failed at step EXEC spawning /usr/bin/spawn-fcgi: No such file or directory
-- Subject: Process /usr/bin/spawn-fcgi could not be executed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- The process /usr/bin/spawn-fcgi could not be executed and failed.
-- 
-- The error number returned by this process is 2.
Oct 10 01:04:43 <hostname> systemd[1]: munin-fcgi-graph.service: Control process exited, code=exited status=203
Oct 10 01:04:43 <hostname> systemd[1]: Failed to start Munin FastCGI Graph.
-- Subject: Unit munin-fcgi-graph.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit munin-fcgi-graph.service has failed.
-- 
-- The result is failed.
Oct 10 01:04:43 <hostname> systemd[1]: munin-fcgi-graph.service: Unit entered failed state.
Oct 10 01:04:43 <hostname> audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=munin-fcgi-graph comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
Oct 10 01:04:43 <hostname> systemd[1]: munin-fcgi-graph.service: Failed with result 'exit-code'.
-------------

2. nginx reference

-- Subject: Unit munin-fcgi-graph.service has begun start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit munin-fcgi-graph.service has begun starting up.
Oct 10 01:05:47 <hostname> spawn-fcgi[17209]: spawn-fcgi: can't find user name nginx
Oct 10 01:05:47 <hostname> systemd[1]: munin-fcgi-graph.service: Control process exited, code=exited status=255
Oct 10 01:05:47 <hostname> systemd[1]: Failed to start Munin FastCGI Graph.
-- Subject: Unit munin-fcgi-graph.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit munin-fcgi-graph.service has failed.
-- 
-- The result is failed.
Oct 10 01:05:47 <hostname> audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=munin-fcgi-graph comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
Oct 10 01:05:47 <hostname> systemd[1]: munin-fcgi-graph.service: Unit entered failed state.
Oct 10 01:05:47 <hostname> systemd[1]: munin-fcgi-graph.service: Failed with result 'exit-code'.

Comment 1 d. johnson 2016-10-10 19:41:34 UTC
Thanks for the reports.  See if this build fixes the issues:

http://koji.fedoraproject.org/koji/buildinfo?buildID=808455

Comment 2 Gabriele Pohl 2016-10-10 22:33:44 UTC
The service scripts still refer to user nginx:

# cat /usr/lib/systemd/system/munin-fcgi-html.service

[Unit]
Description=Munin FastCGI HTML
Documentation=man:spawn-fcgi

[Service]
Type=forking
PIDFile=/run/munin/fcgi-html.pid
ExecStart=/usr/bin/spawn-fcgi -s /run/munin/fcgi-html.sock -U nginx -u munin -g munin /var/www/cgi-bin/munin-cgi-html -P /run/munin/fcgi-html.pid

[Install]
WantedBy=multi-user.target

---------

● munin-fcgi-html.service - Munin FastCGI HTML
   Loaded: loaded (/usr/lib/systemd/system/munin-fcgi-html.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Tue 2016-10-11 00:24:00 CEST; 9s ago
     Docs: man:spawn-fcgi
  Process: 4906 ExecStart=/usr/bin/spawn-fcgi -s /run/munin/fcgi-html.sock -U nginx -u munin -g munin /var/www/cgi-bin/munin-cgi-html -P /run/munin/fcgi-html.pid (code=exited, status=255)
 Main PID: 4202 (code=exited, status=13)

Oct 11 00:24:00 hostname systemd[1]: Starting Munin FastCGI HTML...
Oct 11 00:24:00 hostname spawn-fcgi[4906]: spawn-fcgi: can't find user name nginx
Oct 11 00:24:00 hostname systemd[1]: munin-fcgi-html.service: Control process exited, code=exited status=255
Oct 11 00:24:00 hostname systemd[1]: Failed to start Munin FastCGI HTML.
Oct 11 00:24:00 hostname systemd[1]: munin-fcgi-html.service: Unit entered failed state.
Oct 11 00:24:00 hostname systemd[1]: munin-fcgi-html.service: Failed with result 'exit-code'.

Comment 3 d. johnson 2016-10-11 03:15:34 UTC
Strange.  The commit log has the change, but it did not make it in.

http://pkgs.fedoraproject.org/cgit/rpms/munin.git/commit/?id=4ffeb061b1856f35f44d8fbe52578072f7b76ed7

Thanks, I'll rebuild it again after an import.

Comment 4 Fedora Update System 2016-11-02 13:30:40 UTC
munin-2.0.27-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9ec28cd119

Comment 5 Fedora Update System 2016-11-02 13:31:44 UTC
munin-2.0.27-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-13d6b40ace

Comment 6 Fedora Update System 2016-11-02 13:32:50 UTC
munin-2.0.27-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0d54d65d93

Comment 7 Fedora Update System 2016-11-02 13:34:09 UTC
munin-2.0.27-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-0b923d14d2

Comment 8 Fedora Update System 2016-11-02 13:34:59 UTC
munin-2.0.27-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-464c047938

Comment 9 Fedora Update System 2016-11-04 17:20:26 UTC
munin-2.0.27-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-464c047938

Comment 10 Fedora Update System 2016-11-04 17:22:42 UTC
munin-2.0.27-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-0b923d14d2

Comment 11 Fedora Update System 2016-11-05 03:32:30 UTC
munin-2.0.27-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-13d6b40ace

Comment 12 Fedora Update System 2016-11-05 03:50:50 UTC
munin-2.0.27-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0d54d65d93

Comment 13 Fedora Update System 2016-11-05 18:56:31 UTC
munin-2.0.27-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9ec28cd119

Comment 14 Fedora Update System 2016-11-06 01:52:16 UTC
munin-2.0.27-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0d54d65d93

Comment 15 Fedora Update System 2016-12-11 06:35:05 UTC
munin-2.0.28-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ef830e649f

Comment 16 Fedora Update System 2016-12-11 06:35:45 UTC
munin-2.0.28-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b5dbca9882

Comment 17 Fedora Update System 2016-12-11 06:36:17 UTC
munin-2.0.28-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-82a6c0b1bb

Comment 18 Fedora Update System 2016-12-11 06:36:48 UTC
munin-2.0.28-2.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-c17be6a0d6

Comment 19 Fedora Update System 2016-12-12 12:46:16 UTC
munin-2.0.28-2.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-c17be6a0d6

Comment 20 Fedora Update System 2016-12-12 12:47:57 UTC
munin-2.0.28-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-82a6c0b1bb

Comment 21 Fedora Update System 2016-12-12 13:23:13 UTC
munin-2.0.28-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b5dbca9882

Comment 22 Fedora Update System 2016-12-12 13:25:47 UTC
munin-2.0.28-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ef830e649f

Comment 23 Fedora Update System 2016-12-22 05:23:35 UTC
munin-2.0.28-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2016-12-22 06:48:44 UTC
munin-2.0.28-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 25 Fedora Update System 2016-12-27 07:18:58 UTC
munin-2.0.28-2.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 26 Fedora Update System 2016-12-27 17:17:46 UTC
munin-2.0.28-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.