Bug 138330 - (IT_49888) dvdrecord stall sometimes when buring dvd on a usb drive
dvdrecord stall sometimes when buring dvd on a usb drive
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
: 156613 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-08 06:28 EST by Pierre Amadio
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-29 07:55:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sysreport plus log file of what happen with debug kernel (841.09 KB, text/plain)
2004-11-08 06:32 EST, Pierre Amadio
no flags Details
sysreport plus log file of what happen with debug kernel (841.09 KB, application/octet-stream)
2004-11-08 06:37 EST, Pierre Amadio
no flags Details
logs with http://people.redhat.com/~lwoodman/RHEL3/ (30.24 KB, application/octet-stream)
2004-11-08 06:41 EST, Pierre Amadio
no flags Details

  None (edit)
Description Pierre Amadio 2004-11-08 06:28:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
Sometimes when using dvdrecord (dvdrtools v0.1.3 /RH3), dvdrecord stalls. 
I am using an USB DVD writer.  
After this problem occurs, the process dvdrecord cannot be killed (
the same as  
super user), the DVD writer is no longer available 

Once the dvd burner has been restarted, user can kill the dvdrecord
process and the machine works regularly afterward.


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.burn a dvd
2.sometimes it fail

    

Actual Results:  sometimes it fail , accessing the dvd drive is not
possible anymore untill the dvd drive has been stopped and started.

Expected Results:  less burning failed and a possibility to cope with
the dvd burner afterward without having to restart it physically.

Additional info:

using "options ehci-hcd log2_irq_thresh=5 " decrease the problem's
apparition frequency:

1 burning fails every 40 (average) burn without the option.
with the option, user was able to burns dvd correctly 250 times before
encoutering the problem
Comment 1 Pierre Amadio 2004-11-08 06:32:31 EST
Created attachment 106273 [details]
sysreport plus log file of what happen with debug kernel
Comment 2 Pierre Amadio 2004-11-08 06:37:43 EST
Created attachment 106274 [details]
sysreport plus log file of what happen with debug kernel

kernel is a recompiled	2.4.21-20.EL .
Options that have been changed are:CONFIG_USB_DEBUG=y and 
CONFIG_USB_STORAGE_DEBUG=y
Comment 3 Pierre Amadio 2004-11-08 06:38:47 EST
Translation of the README for attachement 106274 :

1.gravure.* file match what happen when burning proceed correctly.
plouf.* file match what happen when there is a problem in the burning
process:
faio_wait_on_buffer for writer timed out in dvdrecord.
There has been no attempt to kill dvdrecord
Comment 4 Pierre Amadio 2004-11-08 06:41:37 EST
Created attachment 106275 [details]
logs with http://people.redhat.com/~lwoodman/RHEL3/
Comment 7 Pierre Amadio 2004-11-26 03:51:46 EST
actually the setting of "options ehci-hcd log2_irq_thresh=5 " does not
reduce the probability of having the problem occuring.
Comment 9 Pete Zaitcev 2005-06-28 14:38:56 EDT
We know that EHCI locks up under load in kernel 2.4. There was a number
of scenarios. Some were related to specific hardware.

David Brownell supplied me with some fixes, but integrating them into 2.4
was risky, so I only applied about half to Marcelo's tree. I suppose we
could try to pull at least those into RHEL 3 and pray that Pierre's
specific failure is covered. But I don't see it happening.

The realistic option is to plan a migration to RHEL 4.
Comment 10 Bastien Nocera 2005-06-29 07:42:53 EDT
*** Bug 156613 has been marked as a duplicate of this bug. ***
Comment 11 Bastien Nocera 2005-06-29 07:55:25 EDT
Thanks. I'm closing this as "Next release" as the problem isn't that severe
(mighty annoying probably, but not severe).

Note You need to log in before you can comment on or make changes to this bug.