Bug 1383306 - Unhandled exception with 'perf' pollster
Summary: Unhandled exception with 'perf' pollster
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ceilometer
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 10.0 (Newton)
Assignee: Mehdi ABAAKOUK
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-10 11:52 UTC by Yurii Prokulevych
Modified: 2016-12-14 16:15 UTC (History)
7 users (show)

Fixed In Version: openstack-ceilometer-7.0.0-2.2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:15:25 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 384818 None None None 2016-10-11 05:39:07 UTC
OpenStack gerrit 384819 None None None 2016-10-11 16:31:09 UTC

Description Yurii Prokulevych 2016-10-10 11:52:06 UTC
Description of problem:
-----------------------
Traceback in ceilometer/compute.log:

2016-10-10 11:48:11.681 21282 INFO ceilometer.agent.manager [-] Polling pollster perf.instructions in the context of meter_source
2016-10-10 11:48:11.683 21282 ERROR ceilometer.compute.pollsters.perf [-] Could not get perf events for e243077b-d9f1-4626-b95b-2472728b8c3d: 'perf.cpu_cycles'
2016-10-10 11:48:11.683 21282 ERROR ceilometer.compute.pollsters.perf Traceback (most recent call last):
2016-10-10 11:48:11.683 21282 ERROR ceilometer.compute.pollsters.perf   File "/usr/lib/python2.7/site-packages/ceilometer/compute/pollsters/perf.py", line 75, in get_samples
2016-10-10 11:48:11.683 21282 ERROR ceilometer.compute.pollsters.perf     instance,
2016-10-10 11:48:11.683 21282 ERROR ceilometer.compute.pollsters.perf   File "/usr/lib/python2.7/site-packages/ceilometer/compute/pollsters/perf.py", line 44, in _populate_cache
2016-10-10 11:48:11.683 21282 ERROR ceilometer.compute.pollsters.perf     instance, self._inspection_duration)
2016-10-10 11:48:11.683 21282 ERROR ceilometer.compute.pollsters.perf   File "/usr/lib/python2.7/site-packages/ceilometer/compute/virt/libvirt/inspector.py", line 290, in inspect_perf_events
2016-10-10 11:48:11.683 21282 ERROR ceilometer.compute.pollsters.perf     cpu_cycles=perf["perf.cpu_cycles"],
2016-10-10 11:48:11.683 21282 ERROR ceilometer.compute.pollsters.perf KeyError: 'perf.cpu_cycles'
2016-10-10 11:48:11.683 21282 ERROR ceilometer.compute.pollsters.perf 



Version-Release number of selected component (if applicable):
-------------------------------------------------------------
openstack-ceilometer-common-7.0.0-0.20160928024313.67bbd3f.el7ost.noarch
openstack-ceilometer-compute-7.0.0-0.20160928024313.67bbd3f.el7ost.noarch
openstack-ceilometer-notification-7.0.0-0.20160928024313.67bbd3f.el7ost.noarch
openstack-ceilometer-api-7.0.0-0.20160928024313.67bbd3f.el7ost.noarch
python-ceilometerclient-2.6.1-1.el7ost.noarch
openstack-ceilometer-polling-7.0.0-0.20160928024313.67bbd3f.el7ost.noarch
openstack-ceilometer-central-7.0.0-0.20160928024313.67bbd3f.el7ost.noarch
puppet-ceilometer-9.4.0-1.el7ost.noarch
python-ceilometer-7.0.0-0.20160928024313.67bbd3f.el7ost.noarch
openstack-ceilometer-collector-7.0.0-0.20160928024313.67bbd3f.el7ost.noarch



How reproducible:
-----------------
100%

Steps to Reproduce:
-------------------
1. Deploy overcloud.
2. Deploy VM.
3. Check ceilometer/compute.log on compute node.

Additional info:
----------------
Virtual setup - 3Controllers + 1Compute + 1Ceph

Comment 2 Yurii Prokulevych 2016-10-10 13:33:58 UTC
Packages on the compute:
------------------------
libvirt-client-2.0.0-10.el7.x86_64
libvirt-daemon-config-nwfilter-2.0.0-10.el7.x86_64
libvirt-daemon-driver-interface-2.0.0-10.el7.x86_64
libvirt-daemon-driver-network-2.0.0-10.el7.x86_64
libvirt-daemon-driver-nodedev-2.0.0-10.el7.x86_64
libvirt-daemon-config-network-2.0.0-10.el7.x86_64
libvirt-daemon-driver-qemu-2.0.0-10.el7.x86_64
libvirt-2.0.0-10.el7.x86_64
libvirt-daemon-driver-nwfilter-2.0.0-10.el7.x86_64
libvirt-daemon-driver-secret-2.0.0-10.el7.x86_64
libvirt-daemon-kvm-2.0.0-10.el7.x86_64
libvirt-python-2.0.0-2.el7.x86_64
libvirt-daemon-2.0.0-10.el7.x86_64
libvirt-daemon-driver-lxc-2.0.0-10.el7.x86_64
libvirt-daemon-driver-storage-2.0.0-10.el7.x86_64

qemu-kvm-rhev-2.6.0-27.el7.x86_64
libvirt-daemon-driver-qemu-2.0.0-10.el7.x86_64
ipxe-roms-qemu-20160127-5.git6366fa7a.el7.noarch
qemu-img-rhev-2.6.0-27.el7.x86_64
qemu-kvm-common-rhev-2.6.0-27.el7.x86_64

Comment 3 Scott Lewis 2016-10-10 19:51:42 UTC
removing Target Milestone until the bug has been triaged

Comment 4 Mehdi ABAAKOUK 2016-10-11 05:33:21 UTC
I confirm that the required libvirt version for this perf information is >= 2.3.0, I will ignore them when libvirt is too old.

Comment 7 Mehdi ABAAKOUK 2016-11-07 14:18:17 UTC
*** Bug 1386453 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2016-12-14 16:15:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.