Bug 138342 - sound-juicer fails to detect some cds
sound-juicer fails to detect some cds
Status: CLOSED DUPLICATE of bug 135538
Product: Fedora
Classification: Fedora
Component: sound-juicer (Show other bugs)
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
Depends On:
  Show dependency treegraph
Reported: 2004-11-08 08:33 EST by David Nielsen
Modified: 2013-03-13 00:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-04-14 14:25:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 335071 Normal NEW Apache httpd getattr denial on RHEL7 after restart of Pulp Never

  None (edit)
Description David Nielsen 2004-11-08 08:33:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041027 Epiphany/1.4.4

Description of problem:
When testing sound-juicer against various cds I found that with some
cds it will return and empty tracklisting dialog, my test cd for this
is Moby's 18 which appears in Musicbrainz - now not only does
sound-juicer not find the track names (like in #135538) it omits the
track listing, and other cd information completely as if there was no
CD inserted. So the user can't even enter the data 

As a sidenote grip finds the test CD fine, as well as the cd data.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Insert test cd


Actual Results:  get no information posted what so ever.

Expected Results:  correctly detected CD and fetched tracklisting

Additional info:
Comment 1 David Nielsen 2006-02-14 08:41:32 EST
This bug returned recently, my test CD here is Jimi Hendrix - The Ultimate

It shows up correctly looked up Rhythmbox but in Sound-juicer it comes up as

The CD is known by Musicbrainz as are all the cases I've hit so far. 
Comment 2 John Thacker 2006-03-07 22:54:25 EST
The important thing is not just the CD being known by Musicbrainz, but also the
particular DiscID.

From: http://musicbrainz.org/cd_submission.html

"However, there is a downside to this as well. Audio CD-ROMs are usually
produced in large batches, that may include thousands if not millions of copies
of one CD. Once a record company is done selling that one batch, or a record
company in another country wants to print up a batch of the same CD, they will
make another batch. There are over 10 different pressings for the album 'The
Dark Side of the Moon' by Pink Floyd, for instance.

If the CDs from the new batch are off by one sector (as mentioned above) they
will have a different unique Disc ID.


Let's say you use one of the CD Submission tools to submit a CD and you find
that MusicBrainz doesn't know about the CD. You then proceed to select the
artist and then MusicBrainz shows you a list of CDs and your CD is right there
is in the list. What's wrong?

There may be a few things going on:

    * MusicBrainz may not have any Disc IDs for this album.
    * MusicBrainz may have a different Disc ID than you have, thus MusicBrainz
already knows about a different pressing of the CD. 

In either case, you should select the matching CD and let MusicBrainz create
another association for you. This means that MusicBrainz will now know about the
new Disc ID that you just reported. The next time you want to look up this CD,
MusicBrainz will gladly deliver the data to you."
Comment 3 John Thacker 2006-03-07 22:55:57 EST
And Rhythmbox uses FreeDB, not Musicbrainz, so some discs will be known by it
but not sound-juicer.  (Musicbrainz has higher consistency and quality in the
CDs it has, but it doesn't have as many albums and its DiscIDs are more precise
and must be entered for different pressings.)
Comment 4 John Thacker 2006-03-08 15:46:47 EST
Please use sound-juicer's "Submit Track Data" to add the DiscID to the database.
 This is not a bug, just the particular DiscID from a different pressing (that
writes tracks to slightly different sectors) does not exist in the database. 
I've tried it with many different CDs and it works fine if the DiscID is already
added.  If not, it's easy and very fast with the newer sound-juicer to submit an
additional DiscID for a CD.
Comment 5 John Thacker 2006-04-07 12:08:23 EDT
Like bug 135538, this should be closed.  sound-juicer-2.14.1 fixes the fallback
to FreeDB if MusicBrainz doesn't have the CD information.  rhythmbox had this
all along, which is why you saw different results from rhythmbox and
sound-juicer.  sound-juicer-2.14.1 is in updates-testing now.
Comment 6 John Thacker 2006-04-14 14:25:15 EDT
Duplicate caused by sound-juicer prior to 2.14.1 not correctly falling back to
FreeDB if a CD DiscID is not in MusicBrainz.

*** This bug has been marked as a duplicate of 135538 ***

Note You need to log in before you can comment on or make changes to this bug.