Bug 138346 - unable to connect to the server using console port
unable to connect to the server using console port
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: util-linux (Show other bugs)
2.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Karel Zak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-08 09:22 EST by Chakravarthi V S
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-08 06:39:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chakravarthi V S 2004-11-08 09:22:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4)
Gecko/20030624 Netscape/7.1 (ax)

Description of problem:
Hi,

trying to connect to the linux server using console port, but it does
work.
console port is managed by agetty and it is started using following
command in inittab

S1:12345:respawn:/sbin/agetty -t 60 -L ttyS1 19200

when i try to check the process with ps command i dont find the porcess.

tried running on command line

#strace -o /tmp/output /sbin/agetty -t 60 -L ttyS1 19200

i observe the following error message

ioctl(0, 0x5401, {B19200 -opost -isig -icanon -echo ...}) = 0
chown32(0xbffffa42, 0, 0)               = 0
chmod("ttyS1", 0600)                    = 0
getpid()                                = 24595
ioctl(0, 0x5410, [24595])               = -1 ENOTTY (Inappropriate
ioctl for dev
ice)
ioctl(0, 0x540b, 0x2)                   = 0
ioctl(0, 0x5402, {B19200 -opost -isig -icanon -echo ...}) = 0
fcntl64(0, 0x3, 0, 0xcbe)               = 34818
fcntl64(0, 0x4, 0x8002, 0xbffffa42)     = 0
alarm(60)                               = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
rt_sigaction(SIGCHLD, NULL, {SIG_DFL}, 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
nanosleep({1, 0}, {1, 0})               = 0
ioctl(0, 0x540b, 0)                     = 0
uname({sys="Linux", node="nmhost01", ...}) = 0
write(1, "\r\n", 2)                     = 2
open("/etc/issue", O_RDONLY|O_LARGEFILE) = 3
ioctl(0, 0x5403, {B19200 opost -isig -icanon -echo ...}) = -1 EINTR
(Interrupted
 system call)
--- SIGALRM (Alarm clock) ---
+++ killed by SIGALRM +++

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run manually 
2. init q
3. no logs
    

Additional info:
Comment 1 Elliot Lee 2004-12-03 13:24:54 EST
When you don't see the agetty process running, what does '/sbin/fuser
-uv /dev/ttyS1' say when run as root?
Comment 2 Chakravarthi V S 2005-02-10 09:15:55 EST
as it is critical, i restarted the machine and it worked, 

thanks for the help
Comment 3 Karel Zak 2005-09-08 06:39:02 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.

Users who have experienced this problem are encouraged to upgrade to the latest
update release, and if this issue is still reproduceable, please contact the Red
Hat Global Support Services page on our website for technical support options:
https://www.redhat.com/support

If you have a telephone based support contract, you may contact Red Hat at
1-888-GO-REDHAT for technical support for the problem you are experiencing. 

Note You need to log in before you can comment on or make changes to this bug.