Red Hat Bugzilla – Bug 138357
pygtk2 needs python-abi requirement
Last modified: 2007-11-30 17:10:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux; X11; en_US) (KHTML, like Gecko)
Description of problem:
Although I did not update python to version 2.4 pygtk2 (and pyorbit) install
without a conflict and installed stuff into /usr/lib/python2.4
Version-Release number of selected component (if applicable):
Steps to Reproduce:
1. update pygtk2 and pyorbit without updating python
2. look were things are installed
pygtk2-2.4.1-2 lists python2 >= 2.3 as requirement, but installs into
So it should rather have listed python2 >= 2.4 as requirement.
(otherwise package managers like apt will automatically upgrade it
without realising that it won't work without python2.4)
Is this still an issue? RPM now adds an automatic dependency on python-abi .
Closing as NOTABUG due to lack of response and the fact that packages no longer
need to explicitly require python-abi.