Bug 138357 - pygtk2 needs python-abi requirement
pygtk2 needs python-abi requirement
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pygtk2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-08 10:44 EST by Sammy
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 13:12:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2004-11-08 10:44:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux; X11; en_US) (KHTML, like Gecko)

Description of problem:
Although I did not update python to version 2.4 pygtk2 (and pyorbit) install
without a conflict and installed stuff into /usr/lib/python2.4

Version-Release number of selected component (if applicable):
pygtk2-2.4.1-1

How reproducible:
Always

Steps to Reproduce:
1. update pygtk2 and pyorbit without updating python
2. look were things are installed
3.
    

Additional info:
Comment 1 David Fraser 2004-12-20 07:35:47 EST
pygtk2-2.4.1-2 lists python2 >= 2.3 as requirement, but installs into
/usr/lib/python2.4/site-packages
So it should rather have listed python2 >= 2.4 as requirement.
(otherwise package managers like apt will automatically upgrade it
without realising that it won't work without python2.4)
Comment 2 Matthew Barnes 2006-11-04 17:15:00 EST
Is this still an issue?  RPM now adds an automatic dependency on python-abi [1].

[1] http://fedoraproject.org/wiki/Packaging/Python

Comment 3 Matthew Barnes 2007-01-02 13:12:07 EST
Closing as NOTABUG due to lack of response and the fact that packages no longer
need to explicitly require python-abi.

Note You need to log in before you can comment on or make changes to this bug.