Bug 1383646 - libX11-1.6.4 stopped supporting cs_CZ.UTF-8 locale
Summary: libX11-1.6.4 stopped supporting cs_CZ.UTF-8 locale
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libX11
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1383967 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-11 10:58 UTC by Petr Pisar
Modified: 2018-04-03 12:03 UTC (History)
5 users (show)

Fixed In Version: libX11-1.6.5-1.fc25 libX11-1.6.5-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-05 18:59:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 98219 None None None 2016-10-14 17:09:12 UTC
Red Hat Bugzilla 1408162 None None None Never
Red Hat Bugzilla 1426924 None None None Never

Internal Links: 1408162 1426924

Description Petr Pisar 2016-10-11 10:58:06 UTC
libX11-1.6.4 broke cs_CZ.UTF-8 locale support:

$ locale
LANG=cs_CZ.UTF-8
LC_CTYPE="cs_CZ.UTF-8"
LC_NUMERIC="cs_CZ.UTF-8"
LC_TIME="cs_CZ.UTF-8"
LC_COLLATE="cs_CZ.UTF-8"
LC_MONETARY="cs_CZ.UTF-8"
LC_MESSAGES="cs_CZ.UTF-8"
LC_PAPER="cs_CZ.UTF-8"
LC_NAME="cs_CZ.UTF-8"
LC_ADDRESS="cs_CZ.UTF-8"
LC_TELEPHONE="cs_CZ.UTF-8"
LC_MEASUREMENT="cs_CZ.UTF-8"
LC_IDENTIFICATION="cs_CZ.UTF-8"
LC_ALL=

$ xterm
Warning: locale not supported by Xlib, locale set to C

I have libX11-1.6.4-1.fc26.x86_64. I guess F25 is also affected. libX11-1.6.3-3.fc24.x86_64 in F24 is fine.

Comment 1 Petr Pisar 2017-01-30 18:24:06 UTC
Upstream accepted a fix <https://cgit.freedesktop.org/xorg/lib/libX11/commit/?id=23d9623c661694aba8cf1e8f277dffa7a86cf065>. Could you please apply it to Fedora packages?

The bug makes Fedora unusable for Czech users.

Comment 2 Petr Pisar 2017-03-02 12:01:08 UTC
Upstream released 1.6.5 that should contain the commit.

Comment 3 Petr Pisar 2017-04-25 05:29:01 UTC
*** Bug 1383967 has been marked as a duplicate of this bug. ***

Comment 4 Petr Pisar 2017-04-25 05:31:23 UTC
As F24 support will end soon or later, I will have to upgrade to F25 and I'm getting nervous about Fedora libX11 maintainers ignoring this serious bug. If there will be no action from their side, I will apply the fix into libX11 package myself.

Comment 5 Fedora Update System 2017-05-03 17:34:14 UTC
libX11-1.6.5-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-51dfc68129

Comment 6 Fedora Update System 2017-05-03 17:34:33 UTC
libX11-1.6.5-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8949dcbd88

Comment 7 Fedora Update System 2017-05-04 20:03:18 UTC
libX11-1.6.5-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-51dfc68129

Comment 8 Fedora Update System 2017-05-04 22:06:44 UTC
libX11-1.6.5-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8949dcbd88

Comment 9 Fedora Update System 2017-05-05 18:59:13 UTC
libX11-1.6.5-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2017-05-06 17:11:32 UTC
libX11-1.6.5-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.