Bug 1383873 - ValueError: Device 'sdd4' not in tree
ValueError: Device 'sdd4' not in tree
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
25
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:6ab746c4addfa4066e33bd9d853...
:
: 1404828 1408729 (view as bug list)
Depends On:
Blocks: F26AlphaFreezeException
  Show dependency treegraph
 
Reported: 2016-10-11 23:06 EDT by Sebastian
Modified: 2017-03-29 01:05 EDT (History)
21 users (show)

See Also:
Fixed In Version: python-blivet-2.1.7-8.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-29 01:05:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (1.21 MB, text/plain)
2016-10-11 23:07 EDT, Sebastian
no flags Details
File: anaconda.log (80.34 KB, text/plain)
2016-10-11 23:07 EDT, Sebastian
no flags Details
File: environ (618 bytes, text/plain)
2016-10-11 23:07 EDT, Sebastian
no flags Details
File: journalctl (330.46 KB, text/plain)
2016-10-11 23:07 EDT, Sebastian
no flags Details
File: lsblk_output (3.45 KB, text/plain)
2016-10-11 23:07 EDT, Sebastian
no flags Details
File: nmcli_dev_list (904 bytes, text/plain)
2016-10-11 23:07 EDT, Sebastian
no flags Details
File: os_info (449 bytes, text/plain)
2016-10-11 23:07 EDT, Sebastian
no flags Details
File: program.log (121.85 KB, text/plain)
2016-10-11 23:07 EDT, Sebastian
no flags Details
File: storage.log (615.59 KB, text/plain)
2016-10-11 23:07 EDT, Sebastian
no flags Details
File: ifcfg.log (6.23 KB, text/plain)
2016-10-11 23:08 EDT, Sebastian
no flags Details

  None (edit)
Description Sebastian 2016-10-11 23:06:46 EDT
Description of problem:
Hello, i am using easy2boot. I think i have a problem with the virtual device that easy2boot created.

/dev/sdd4

The easy2boot uses GRUB4DOS and boots from /dev/sdd1; an active NTFS partition. The Fedora25 ISO is loaded from /dev/sdd1/_ISO/LINUX/ into the virtual device /sdd4,
from which the livesystem is booting.

Side note: easy2boot had no problems with Fedora23 and Fedora24 Final. Their anaconda is not complaining about /dev/sdd4.

I am not able to install ANY Fedora 25 release!

/run/media/liveuser/TOSHIBABOOT/_ISO/LINUX/Fedora-Design_suite-Live-x86_64-25_Alpha-2.iso
/run/media/liveuser/TOSHIBABOOT/_ISO/LINUX/Fedora-Jam_KDE-Live-x86_64-25_Alpha-2.iso
/run/media/liveuser/TOSHIBABOOT/_ISO/LINUX/Fedora-MATE_Compiz-Live-x86_64-25_Alpha-2.iso
/run/media/liveuser/TOSHIBABOOT/_ISO/LINUX/Fedora-MATE_Compiz-Live-x86_64-25_Beta-1.1.iso
/run/media/liveuser/TOSHIBABOOT/_ISO/LINUX/Fedora-SoaS-Live-x86_64-25_Alpha-2.iso
/run/media/liveuser/TOSHIBABOOT/_ISO/LINUX/Fedora-Workstation-dvd-x86_64-25_Beta-1.1.iso
/run/media/liveuser/TOSHIBABOOT/_ISO/LINUX/Fedora-Workstation-Live-x86_64-25_Beta-1.1.iso
/run/media/liveuser/TOSHIBABOOT/_ISO/LINUX/Fedora-Xfce-Live-x86_64-25_Beta-1.1.iso

Version-Release number of selected component:
anaconda-core-25.20.4-1.fc25.x86_64

The following was filed automatically by anaconda:
anaconda 25.20.4-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.5/site-packages/blivet/devicetree.py", line 184, in _remove_device
    raise ValueError("Device '%s' not in tree" % dev.name)
  File "/usr/lib/python3.5/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.5/site-packages/blivet/devicetree.py", line 851, in hide
    self._remove_device(device, force=True, modparent=False)
  File "/usr/lib/python3.5/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.5/site-packages/blivet/devicetree.py", line 844, in hide
    self.hide(d)
  File "/usr/lib/python3.5/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 836, in _hide_disks
    self.storage.devicetree.hide(disk)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 963, in on_back_clicked
    self._hide_disks()
ValueError: Device 'sdd4' not in tree

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img root=live:CDLABEL=Fedora-Xfce-Live-25_B-1-1 rd.live.image quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.8.0-0.rc7.git0.1.fc25.x86_64
other involved packages: anaconda-gui-25.20.4-1.fc25.x86_64, python3-blivet-2.1.6-1.fc25.noarch
product:        Fedora
release:        Fedora release 25 (Twenty Five)
screencast.ogv: 
type:           anaconda
version:        25
Comment 1 Sebastian 2016-10-11 23:07:20 EDT
Created attachment 1209415 [details]
File: anaconda-tb
Comment 2 Sebastian 2016-10-11 23:07:24 EDT
Created attachment 1209416 [details]
File: anaconda.log
Comment 3 Sebastian 2016-10-11 23:07:26 EDT
Created attachment 1209417 [details]
File: environ
Comment 4 Sebastian 2016-10-11 23:07:35 EDT
Created attachment 1209418 [details]
File: journalctl
Comment 5 Sebastian 2016-10-11 23:07:36 EDT
Created attachment 1209419 [details]
File: lsblk_output
Comment 6 Sebastian 2016-10-11 23:07:38 EDT
Created attachment 1209420 [details]
File: nmcli_dev_list
Comment 7 Sebastian 2016-10-11 23:07:39 EDT
Created attachment 1209421 [details]
File: os_info
Comment 8 Sebastian 2016-10-11 23:07:43 EDT
Created attachment 1209422 [details]
File: program.log
Comment 9 Sebastian 2016-10-11 23:07:59 EDT
Created attachment 1209423 [details]
File: storage.log
Comment 10 Sebastian 2016-10-11 23:08:01 EDT
Created attachment 1209424 [details]
File: ifcfg.log
Comment 11 Glenn Holmer 2016-11-23 11:28:42 EST
Similar problem has been detected:

1) Start installation of Fedora 25 KDE Spin from USB stick.
2) On "Installation Destination" screen, select first of two hard drives.
3) Select "I will configure partitioning.
4) Error appeared when clicking "Done" button, can't proceed.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img root=live:CDLABEL=Fedora-KDE-Live-25-1-3 rd.live.image quiet
hashmarkername: anaconda
kernel:         4.8.6-300.fc25.x86_64
other involved packages: python3-blivet-2.1.6-4.fc25.noarch, anaconda-gui-25.20.8-1.fc25.x86_64
package:        anaconda-core-25.20.8-1.fc25.x86_64
packaging.log:  
product:        Fedora
reason:         ValueError: Device 'sdb5' not in tree
release:        Fedora release 25 (Twenty Five)
version:        25
Comment 12 Glenn Holmer 2016-11-23 12:12:50 EST
(In reply to Glenn Holmer from comment #11)
> Similar problem has been detected:

> reason:         ValueError: Device 'sdb5' not in tree

sdb is MBR-formatted with four primary partitions. Shouldn't be an error that sdb5 doesn't exist.
Comment 13 Sandeep MJ 2016-12-08 19:41:44 EST
I face the same errors while trying to create a dual boot setup on an existing Windows 10 machine. Created the bootable image (Workstation) with Universal USB Installer.
Comment 14 Luís Carlos Teixeira 2016-12-14 13:31:28 EST
*** Bug 1404828 has been marked as a duplicate of this bug. ***
Comment 15 alfredometere2 2016-12-26 15:21:25 EST
*** Bug 1408729 has been marked as a duplicate of this bug. ***
Comment 16 Alex French 2017-01-07 14:28:38 EST
Similar problem has been detected:

Verified install media, clicked disk setup and selected my 500GB disk, then hit done.. installer crashes.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img root=live:CDLABEL=Fedora-WS-Live-25-1-3 rd.live.image quiet
hashmarkername: anaconda
kernel:         4.8.6-300.fc25.x86_64
other involved packages: python3-blivet-2.1.6-4.fc25.noarch, anaconda-gui-25.20.8-1.fc25.x86_64
package:        anaconda-core-25.20.8-1.fc25.x86_64
packaging.log:  
product:        Fedora
reason:         ValueError: Device 'sda10' not in tree
release:        Fedora release 25 (Twenty Five)
version:        25
Comment 17 Nicolas PLANEL 2017-02-09 15:23:23 EST
Similar problem has been detected:

I boot from usbkey /dev/sdc1

addons:         com_redhat_kdump, com_redhat_docker
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-E-dvd-x86_64-25 quiet
hashmarkername: anaconda
kernel:         4.8.6-300.fc25.x86_64
package:        anaconda-25.20.8-1
product:        Fedora
reason:         ValueError: Device 'sdc4' not in tree
release:        Cannot get release name.
version:        25
Comment 18 Nicolas PLANEL 2017-02-09 15:59:15 EST
This patition ID of /dev/sdc4 is 0
Only with this kind of configuration, anaconda crash be the previous backtrace.
Comment 19 t.soernes 2017-03-01 11:01:14 EST
Similar problem has been detected:

Select a disk, then 'I will configure partitioning'. dev/sdf is the usb device from which the live-cd is booted.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img root=live:CDLABEL=Fedora-Cinnamon-Live-25-1-3 rd.live.image rd.live.check quiet
hashmarkername: anaconda
kernel:         4.8.6-300.fc25.x86_64
other involved packages: anaconda-gui-25.20.8-1.fc25.x86_64, python3-blivet-2.1.6-4.fc25.noarch
package:        anaconda-core-25.20.8-1.fc25.x86_64
packaging.log:  
product:        Fedora
reason:         ValueError: Device 'sdf4' not in tree
release:        Fedora release 25 (Twenty Five)
version:        25
Comment 20 t.soernes 2017-03-01 11:31:18 EST
I found a workaround:
Before booting, press tab and add 'rd.live.ram' to boot options.
Then open the 'disks' program and unmount all the partitions on the USB drive from which you booted the Fedora live disk.
Then eject and disconnect the USB drive. Continue installing as usual.
Comment 21 Ondrej Gajdusek 2017-03-05 16:27:10 EST
Similar problem has been detected:

Description of problem:
During the installation process of F25, the installer pops an error, instead of displaying the partitioning info. I am not able to continue with installation without configuring partitioning.

Version-Release number of selected component (if applicable):
Fedora 25

Steps to Reproduce:
1. Enter BIOS BootMenu, select UEFI:FedoraCD
2. select Test this media and start Fedora
3. run installation tool, select English, click Next
4. enter "INSTALLATION DESTINATION" select drive on which I want to install the system.  For me, it's "ATA KINGSTON SHSS37A" 223.57/223.57 GiB free
5. check manual partitioning, then click "Done"

After that, it raises an error.  I tried to reproduce the same steps on the same HW with F24 and it worked. And I was able to install F24 on selected drive, configure partitioning, etc. It is also reproducible when "Automatic partitioning" is checked.

Actual results:
After clicking onto "Done", Anaconda Installer raises an error.

Expected results:
After clicking onto "Done", I should be able to configure partitioning and continue with the installation.

Additional info:
I am able to reproduce it again and provide more info about this bug. Leave me a comment or email me.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz root=live:CDLABEL=Fedora-WS-Live-25-1-3 rd.live.image quiet
hashmarkername: anaconda
kernel:         4.8.6-300.fc25.x86_64
other involved packages: python3-blivet-2.1.6-4.fc25.noarch, anaconda-gui-25.20.8-1.fc25.x86_64
package:        anaconda-core-25.20.8-1.fc25.x86_64
packaging.log:  
product:        Fedora
reason:         ValueError: Device 'sdd2' not in tree
release:        Fedora release 25 (Twenty Five)
version:        25
Comment 22 Viktor Pogrzebacz 2017-03-13 14:59:48 EDT
Similar problem has been detected:

Trying to install Fedora 25 from USB. In the "Install to Hard Drive" Wizzard under the "Installation Destinantion" step I select the desired (and only) HDD.

No matter what other options I select (I tried all combinations) the error happens. 
I don't know if this has anything to do with it but the HDD contains a broken Fedora installation that I wanted to override.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img root=live:CDLABEL=Fedora-WS-Live-25-1-3 rd.live.image rd.live.check quiet
hashmarkername: anaconda
kernel:         4.8.6-300.fc25.x86_64
other involved packages: python3-blivet-2.1.6-4.fc25.noarch, anaconda-gui-25.20.8-1.fc25.x86_64
package:        anaconda-core-25.20.8-1.fc25.x86_64
packaging.log:  
product:        Fedora
reason:         ValueError: Device 'sdb4' not in tree
release:        Fedora release 25 (Twenty Five)
version:        25
Comment 23 David Lehman 2017-03-16 14:31:42 EDT
Upstream pull request:

  https://github.com/rhinstaller/blivet/pull/560
Comment 24 Adam Williamson 2017-03-20 14:01:28 EDT
+1 FE, sounds like a lot of people are running into this.
Comment 25 Mike Ruckman 2017-03-20 14:09:26 EDT
+1 FE
Comment 26 Kevin Fenzi 2017-03-20 14:17:27 EDT
+1 FE, a number of folks seem to hit this
Comment 27 Adam Williamson 2017-03-20 18:17:22 EDT
That's +3, setting accepted.
Comment 28 Fedora Update System 2017-03-21 12:36:06 EDT
python-blivet-2.1.7-8.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1d70efd57a
Comment 29 Fedora Update System 2017-03-22 11:27:09 EDT
python-blivet-2.1.7-8.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-1d70efd57a
Comment 30 Fedora Update System 2017-03-29 01:05:11 EDT
python-blivet-2.1.7-8.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.