Bug 1383890 - blivet.errors.DeviceError: ('cannot replace active format', 'sdc1')
Summary: blivet.errors.DeviceError: ('cannot replace active format', 'sdc1')
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4500b7b5ba62318399bba544531...
: 1426877 1459595 (view as bug list)
Depends On:
Blocks: F25FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2016-10-12 04:23 UTC by Chris Murphy
Modified: 2017-12-12 11:03 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-12 11:03:35 UTC


Attachments (Terms of Use)
File: anaconda-tb (2.25 MB, text/plain)
2016-10-12 04:23 UTC, Chris Murphy
no flags Details
File: anaconda.log (212.18 KB, text/plain)
2016-10-12 04:23 UTC, Chris Murphy
no flags Details
File: environ (509 bytes, text/plain)
2016-10-12 04:23 UTC, Chris Murphy
no flags Details
File: journalctl (399.45 KB, text/plain)
2016-10-12 04:23 UTC, Chris Murphy
no flags Details
File: lsblk_output (3.43 KB, text/plain)
2016-10-12 04:23 UTC, Chris Murphy
no flags Details
File: lvm.log (814.38 KB, text/plain)
2016-10-12 04:23 UTC, Chris Murphy
no flags Details
File: nmcli_dev_list (1.66 KB, text/plain)
2016-10-12 04:23 UTC, Chris Murphy
no flags Details
File: os_info (518 bytes, text/plain)
2016-10-12 04:23 UTC, Chris Murphy
no flags Details
File: program.log (170.58 KB, text/plain)
2016-10-12 04:23 UTC, Chris Murphy
no flags Details
File: storage.log (581.83 KB, text/plain)
2016-10-12 04:23 UTC, Chris Murphy
no flags Details
File: ifcfg.log (2.43 KB, text/plain)
2016-10-12 04:23 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2016-10-12 04:23:09 UTC
Description of problem:
1. USB stick target contains a previous Fedora 25 installation (auto part) installation.
2. Use auto part, reclaim space, Delete All, to do a new installation.
3. Click Done at Installation Destination, returned to the hub UI and then crash before Begin Installation changes from gray to blue.

Regression: if the USB stick is wipefs'd first, autopart succeeds and the resulting installation is bootable, which is the state the stick was in at step 1 above.

Version-Release number of selected component:
anaconda-core-25.20.4-1.fc25.x86_64

The following was filed automatically by anaconda:
anaconda 25.20.4-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.5/site-packages/blivet/devices/storage.py", line 706, in _set_format
    raise errors.DeviceError("cannot replace active format", self.name)
  File "/usr/lib/python3.5/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.5/site-packages/blivet/devices/storage.py", line 751, in <lambda>
    lambda d, f: d._set_format(f),
  File "/usr/lib/python3.5/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.5/site-packages/blivet/deviceaction.py", line 687, in apply
    self.device.format = None
  File "/usr/lib/python3.5/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.5/site-packages/blivet/actionlist.py", line 75, in add
    action.apply()
  File "/usr/lib/python3.5/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.5/site-packages/blivet/devicetree.py", line 243, in recursive_remove
    self.actions.add(ActionDestroyFormat(leaf))
  File "/usr/lib/python3.5/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.5/site-packages/blivet/blivet.py", line 611, in recursive_remove
    self.devicetree.recursive_remove(device)
  File "/usr/lib/python3.5/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py", line 425, in _recursive_remove
    self.storage.recursive_remove(device)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py", line 447, in _scheduleActions
    self._recursive_remove(device)
blivet.errors.DeviceError: ('cannot replace active format', 'sdc1')

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz root=live:CDLABEL=Fedora-WS-Live-25-20161008-n-0 rd.live.image quiet elevator=noop
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.8.0-0.rc7.git0.1.fc25.x86_64
other involved packages: anaconda-gui-25.20.4-1.fc25.x86_64, python3-blivet-2.1.6-1.fc25.noarch
product:        Fedora
release:        Fedora release 25 (Twenty Five)
type:           anaconda
version:        25

Comment 1 Chris Murphy 2016-10-12 04:23:17 UTC
Created attachment 1209429 [details]
File: anaconda-tb

Comment 2 Chris Murphy 2016-10-12 04:23:19 UTC
Created attachment 1209430 [details]
File: anaconda.log

Comment 3 Chris Murphy 2016-10-12 04:23:20 UTC
Created attachment 1209431 [details]
File: environ

Comment 4 Chris Murphy 2016-10-12 04:23:21 UTC
Created attachment 1209432 [details]
File: journalctl

Comment 5 Chris Murphy 2016-10-12 04:23:22 UTC
Created attachment 1209433 [details]
File: lsblk_output

Comment 6 Chris Murphy 2016-10-12 04:23:25 UTC
Created attachment 1209434 [details]
File: lvm.log

Comment 7 Chris Murphy 2016-10-12 04:23:26 UTC
Created attachment 1209435 [details]
File: nmcli_dev_list

Comment 8 Chris Murphy 2016-10-12 04:23:27 UTC
Created attachment 1209436 [details]
File: os_info

Comment 9 Chris Murphy 2016-10-12 04:23:28 UTC
Created attachment 1209437 [details]
File: program.log

Comment 10 Chris Murphy 2016-10-12 04:23:30 UTC
Created attachment 1209438 [details]
File: storage.log

Comment 11 Chris Murphy 2016-10-12 04:23:31 UTC
Created attachment 1209439 [details]
File: ifcfg.log

Comment 12 Fedora Blocker Bugs Application 2016-10-12 06:09:34 UTC
Proposed as a Blocker for 25-final by Fedora user chrismurphy using the blocker tracking app because:

 Not sure which one is better, but if installing to USB sticks is invalid then it shouldn't crash and they also shouldn't be offered as an installation destination. If USB sticks are a valid destination, then installation should succeed.

Beta criterion:
Reject or disallow invalid disk and volume configurations without crashing. 

Final criterion:
The installer must be able to create and install to any workable partition layout using any file system and/or container format combination offered in a default installer configuration.

Comment 13 joerg.lechner 2016-10-12 09:03:50 UTC
Bug 1371661 - no boot possible from 64GB usb 3.0 flash medium 
This bug describes the situation on my Acer E15 E5-571G, EFI, Win 8.1 on the internal disk.
I can not install F25 Alpha, Beta, also when I reset the 64GB 3.0 USB flash medium with Media Writer (restore function, followed by Gparted, to make the flash medium generally usable again), I found now way to install F25, whether automatic partitioning with reclaim space nor on an other offered way.
Possibly this additional info is helpful to solve this problem.

Comment 14 satellitgo 2016-10-12 12:56:28 UTC
I also have seen this using a mediawriter USB of f25 workstation beta 1.1:

Installation halted after restore disk step with error message

I was trying to install to a usb external HD with a previous install of f25 workstation beta 1.1. 

anaconda was confused and could not discriminate between the booted live usb and the external usb HD. A warning popped up saying install could not proceed.

Install worked after I used another computer to format the usb external HD with gnome disks and retried install.

Comment 15 David Lehman 2016-10-17 16:47:18 UTC
Does anyone know what has it mounted?

22:19:28,620 INFO program: `-sdc1         209715200 root  disk  brw-rw---- `-sdc1      hfsplus     Linux HFS+ ESP                 c7f20a48-bc9b-33dc-a1ef-4e14185f5be6   /run/media/liveuser/Linux HFS+ ESP

Comment 16 Chris Murphy 2016-10-17 16:52:21 UTC
That's an HFS+ volume being used as an EFI system partition because it's Apple hardware.

Comment 17 Adam Williamson 2016-10-17 17:19:05 UTC
Chris: for you, did this only start happening with 25.20.4-1.fc25 ?

Comment 18 Geoffrey Marr 2016-10-17 19:18:23 UTC
Discussed during the 2016-010-17 blocker review meeting: [1]

The decision to classify this bug as an "AcceptedBlocker" was made as it does violate the criteria, however we're aware that the Anaconda team may differ in opinion on classification and we are open to their suggestion either as a comment here or at next weeks meeting.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2016-10-17/f25-blocker-review.2016-10-17-16.02.txt

Comment 19 Chris Murphy 2016-10-17 19:52:08 UTC
The problem doesn't occur with netinstall, Fedora-Workstation-netinst-x86_64-25-20161017.n.0.iso.

The problem does occur with F24 live, Fedora-Workstation-Live-x86_64-24-1.2.iso. Abrt sends me to duplicate bug 1381757, parent bug 1330820.

Comment 20 joerg.lechner 2016-10-18 06:56:33 UTC
Hi,
by case I tried to install F25 Beta in legacy mode on an 64GB flash medium. And surprise it works.
This means Anaconda problem when installing F25 on an USB flash medium in EFI mode,
but in Legacy mode ok. I run an Acer laptop with Win 8.1 on the internal disk.
I think this is good news to find a way to solve this EFI - Anaconda problem.
Kind regards
(this a copy of a thread in the test lists)

Comment 21 joerg.lechner 2016-10-19 07:00:53 UTC
Hi Richard,
this is strange. I am now in F25 EFI on an 32GB USB 3.0 flash medium.
I have made the following tests with the 64GB USB 3.0 flash medium (both 32GB and 64GB are Sandisk Ultra)
Legacy mode: F25 and F24 installation ok
EFI mode: F25 to F22 dracut error, no installation possible on the 64GB stick
                and F25 installation ok on the 32GB stick

What is confusing for me with F25 Alpha I tried to install on an external Pata disk (some hundred GB) connected with an usb adapter (I use always used internal disks from ebay - one of my hobbies is collecting TV films, a disk space consuming job), there also no "EFI installation" was possible. I need now an other TB disk for my hobby, and will it first use for an F25 installation test, but this will take some days to get it.
Strange results, the 64GB stick should be ok, because the "Legacy installation" works. I copy this mail to the 2 Bug reports related to Anaconda.
Kind regards
Joerg

Comment 22 Samantha N. Bueno 2016-10-24 13:31:28 UTC
This has a workaround (non-live installs) and this existed in F24. This is also not a supported use case.

This isn't a blocker.

Comment 23 Geoffrey Marr 2016-10-24 18:31:05 UTC
Discussed during the 2016-10-24 blocker review meeting: [1]

The decision to reclassify this bug as a RejectedBlocker and was made per the Anaconda Team's input as well as the conditionality of this bug.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2016-10-24/f25-blocker-review.2016-10-24-16.01.txt

Comment 24 bsmreker1 2017-02-26 01:23:24 UTC
*** Bug 1426877 has been marked as a duplicate of this bug. ***

Comment 25 nmc 2017-06-07 14:29:09 UTC
*** Bug 1459595 has been marked as a duplicate of this bug. ***

Comment 26 Fedora End Of Life 2017-11-16 18:38:59 UTC
This message is a reminder that Fedora 25 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 25. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '25'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 25 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 27 Fedora End Of Life 2017-12-12 11:03:35 UTC
Fedora 25 changed to end-of-life (EOL) status on 2017-12-12. Fedora 25 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.