Bug 1383956 - Validations should be enabled/installed by default
Summary: Validations should be enabled/installed by default
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 10.0 (Newton)
Assignee: Tomas Sedovic
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-12 09:04 UTC by Tomas Sedovic
Modified: 2016-12-14 16:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:16:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 385371 None None None 2016-10-12 11:45:42 UTC
Launchpad 1632652 None None None 2016-10-12 10:33:06 UTC

Description Tomas Sedovic 2016-10-12 09:04:45 UTC
Description of problem:

In order to enable validations in the GUI, the person installing the undercloud must set `enable_validations = true` before running `openstack undercloud install`. If they don't, the validations won't be available in the UI.

Since they're an important part of the UI, we should make sure they're available in our product. We could of course just document this, but flipping the default would make it more foolproof.


Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1. When installing the undercloud, do not edit undercloud.conf
2. run: openstack undercloud instcall
3.

Actual results:

When you open the UI, no validations are listed.


Expected results:

The UI should list the validations and have them available.


Additional info:

Flipping the default will require a couple of changes to the instack-undercloud repository. I expect that the upstream will make the validations on by default eventually, but not in the Newton/OSP10 timeframe.

Comment 1 Tomas Sedovic 2016-10-12 10:07:37 UTC
I've created a patch upstream:

https://review.openstack.org/#/c/385371/

Not sure it's going to merge but at least we'll be able to track it there.

Comment 2 Tomas Sedovic 2016-10-13 10:31:29 UTC
The patch was merged upstream and backported to the stable/newton branch:

https://review.openstack.org/#/c/385371/
https://review.openstack.org/#/c/385390/

Comment 5 Udi 2016-11-06 14:30:10 UTC
Verified.

Comment 7 errata-xmlrpc 2016-12-14 16:16:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.