Bug 1383989 - znc-1.6.3-5.fc26 FTBFS against OpenSSL 1.1.0
Summary: znc-1.6.3-5.fc26 FTBFS against OpenSSL 1.1.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: znc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nick Bebout
QA Contact: Fedora Extras Quality Assurance
URL: http://apps.fedoraproject.org/koschei...
Whiteboard:
Depends On:
Blocks: 1383740
TreeView+ depends on / blocked
 
Reported: 2016-10-12 10:09 UTC by Jitka Plesnikova
Modified: 2017-01-10 11:48 UTC (History)
2 users (show)

Fixed In Version: znc-1.6.4-1.fc25 znc-1.6.4-1.fc24 znc-1.6.4-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-10 06:48:11 UTC


Attachments (Terms of Use)

Description Jitka Plesnikova 2016-10-12 10:09:06 UTC
Description of problem:
Package znc fails to build from source in Fedora Rawhide.

build.log contains e.g. following errors:

src/Csocket.cpp: In function 'bool InitSSL(ECompType)':
src/Csocket.cpp:587:17: error: 'COMP_rle' was not declared in this scope
   cm = COMP_rle();
                 ^

src/Csocket.cpp:1509:48: error: 'SSLv2_client_method' was not declared in this scope
   m_ssl_ctx = SSL_CTX_new( SSLv2_client_method() );
                                                ^

src/Csocket.cpp: In member function 'CString Csock::GetPeerPubKey() const':
src/Csocket.cpp:2616:26: error: invalid use of incomplete type 'SSL_SESSION {aka struct ssl_session_st}'
  if( pSession && pSession->peer )
                          ^~

src/Csocket.cpp:2622:16: error: invalid use of incomplete type 'EVP_PKEY {aka struct evp_pkey_st}'
    switch( pKey->type )
                ^~

src/Csocket.cpp: In member function 'long int Csock::GetPeerFingerprint(CString&) const':
src/Csocket.cpp:2666:35: error: invalid use of incomplete type 'X509 {aka struct x509_st}'
    snprintf( buf, 3, "%02x", pCert->sha1_hash[i] );
                                   ^~

src/main.cpp:39:8: error: 'CRYPTO_dynlock_value' does not name a type
 static CRYPTO_dynlock_value *dyn_create_callback(const char *file, int line) {
        ^~~~~~~~~~~~~~~~~~~~

This is caused by upgrading openssl from 1:1.0.2j-1.fc26 to 1:1.1.0b-1.fc26.

Additional info:
This package is tracked by Koschei. See:
http://apps.fedoraproject.org/koschei/package/znc

Comment 1 Eli Young 2016-10-17 19:36:43 UTC
Upstream issue: https://github.com/znc/znc/issues/1310

A fix appears to have been merged, but no release has happened since: https://github.com/znc/znc/pull/1311

Comment 2 Eli Young 2016-10-17 19:51:16 UTC
It looks like one of the upstream's dependencies also needs a fix applied, which is still in progress: https://github.com/jimloco/Csocket/pull/64

Comment 3 Fedora Update System 2016-12-16 21:41:11 UTC
znc-1.6.4-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-cd42eb69d8

Comment 4 Fedora Update System 2016-12-16 21:41:24 UTC
znc-1.6.4-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0043a91473

Comment 5 Fedora Update System 2016-12-16 21:41:35 UTC
znc-1.6.4-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-5c73ebbb87

Comment 6 Fedora Update System 2016-12-16 21:41:45 UTC
znc-1.6.3-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b0fcd20624

Comment 7 Fedora Update System 2016-12-19 01:51:11 UTC
znc-1.6.4-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-5c73ebbb87

Comment 8 Fedora Update System 2016-12-19 02:30:23 UTC
znc-1.6.4-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-cd42eb69d8

Comment 9 Fedora Update System 2016-12-20 00:57:12 UTC
znc-1.6.4-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0043a91473

Comment 10 Fedora Update System 2017-01-10 06:48:11 UTC
znc-1.6.4-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2017-01-10 08:19:06 UTC
znc-1.6.4-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2017-01-10 11:48:23 UTC
znc-1.6.4-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.