Bug 1384009 - [RFE] using smart variables based on Host Collections
Summary: [RFE] using smart variables based on Host Collections
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Smart Variables
Version: 6.2.2
Hardware: All
OS: All
medium
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
: 1391824 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-12 11:03 UTC by Anand Agrawal
Modified: 2017-09-11 15:06 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-05 17:06:12 UTC


Attachments (Terms of Use)

Comment 1 orabin 2016-12-29 09:53:09 UTC
*** Bug 1391824 has been marked as a duplicate of this bug. ***

Comment 2 orabin 2017-01-19 12:57:29 UTC
A host can be in more then one host collection.

If there is a host in host collection A and host collection B, and there was a possibility to add these matchers:
host_collection=A will get the value A
host_vollection=B will get the value B
which value should the host get? A or B?

In smart variables you can define the order of which value to use but it's by the type in the matcher e.g if these matchers are defined:
hostgroup=My_hostgroup will get value A
os=My_os will get value B
and a host has hostgoup My_hostgroup and os My_os then for the order: hostgroup,os 
the host will get value A 
and for the order: os,hostgroup 
the host will get value B.

The order creates a priority of which value to use but if host_collection is added to the order there is still no way to prioritize when a host is connected to more then one host collection.

Comment 7 Bryan Kearney 2017-09-05 17:06:12 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in product in the forseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.

Customers can use custom facts on the machine to drive this sort of robust logic in the puppet classes.


Note You need to log in before you can comment on or make changes to this bug.