Bug 1384195 - dmidecode failing with rhel7.3
Summary: dmidecode failing with rhel7.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dmidecode
Version: 7.3
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: 7.4
Assignee: Petr Oros
QA Contact: Mike Gahagan
URL:
Whiteboard:
Depends On:
Blocks: 1366034 1446211 1394638 1401905 1404314
TreeView+ depends on / blocked
 
Reported: 2016-10-12 19:10 UTC by Frank Ramsay (HPE)
Modified: 2019-02-15 03:11 UTC (History)
15 users (show)

Fixed In Version: dmidecode-3.0-3.el7
Doc Type: Bug Fix
Doc Text:
Previously, the dmidecode utilities failed to extract hardware information from the BIOS or the Extensible Firmware Interface (EFI). This update fixes the underlying source code, and dmidecode now work as expected.
Clone Of:
: 1401905 (view as bug list)
Environment:
Last Closed: 2017-08-01 17:53:36 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch that resolves issue. (1.62 KB, application/mbox)
2016-10-12 19:12 UTC, Frank Ramsay (HPE)
no flags Details
output from dmidecode dump-bin (1.93 KB, application/x-gzip)
2016-11-07 13:33 UTC, Frank Ramsay (HPE)
no flags Details
output from dmidecode (5.49 KB, application/x-gzip)
2016-11-07 13:34 UTC, Frank Ramsay (HPE)
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1858 0 normal SHIPPED_LIVE dmidecode bug fix and enhancement update 2017-08-01 18:04:08 UTC

Description Frank Ramsay (HPE) 2016-10-12 19:10:05 UTC
Description of problem:
   	
1066857: dmidecode failing with rhel7.3
See another incident 	Check for related patches 	Update this incident
Incident ID:
	

Query: [Previous][Previous Query Result] [Next]
Jump To: [Description] [Printer-friendly view]

Incident Identification
Incident #: 	1066857 	Classification: 	bug
Status: 	open 	Priority: 	1
Summary: 	dmidecode failing with rhel7.3
Opened Date: 	Oct 12 2016 07:33:51AM 	Age: 	0
Category: 	software 	Customer Reported: 	F
Incident Ownership
Assigned Group: 	linux-kernel 	Project: 	redhatlinux
Assigned Engineer: 	framsay@sgi.com 	Submitter: 	jsulliva@sgi.com
CC List: 	winkler patrow rja tee jgrisham nlebarron natashag yakesh
Incident Management/Status
Planned Fix Release: 	rhel7.3 	Planned Fix Date: 	 
Fix Policy: 	  	Fix Plan: 	propose for external bug system
Modified User: 	framsay@sgi.com 	Modified Date: 	Oct 12 2016 12:04:17PM
Submittal Details
SGI Only: 	  	Submitter Machine: 	137.38.226.47

Description:

Any "dmidecode -s" executions results in errors being printed.  First noticed
with the rhel7.3 install

[root@dafy19 tools]# dmidecode -s chassis-type
Other
Invalid entry length (16). Fixed up to 11.
[root@dafy19 tools]# 
[root@dafy19 tools]# 
[root@dafy19 tools]# uname -a
Linux dafy19 3.10.0-510.el7.x86_64 #1 SMP Wed Sep 21 14:44:14 EDT 2016 x86_64 x86_64 x86_64 GNU/Linux
[root@dafy19 tools]# cat /etc/*release
NAME="Red Hat Enterprise Linux Server"
VERSION="7.3 (Maipo)"
ID="rhel"
ID_LIKE="fedora"
VERSION_ID="7.3"
PRETTY_NAME="Red Hat Enterprise Linux Server 7.3 Beta (Maipo)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:7.3:beta:server"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"

REDHAT_BUGZILLA_PRODUCT="Red Hat Enterprise Linux 7"
REDHAT_BUGZILLA_PRODUCT_VERSION=7.3
REDHAT_SUPPORT_PRODUCT="Red Hat Enterprise Linux"
REDHAT_SUPPORT_PRODUCT_VERSION="7.3 Beta"
Red Hat Enterprise Linux Server release 7.3 Beta (Maipo)
SGI Management Center Admin Node 3.4.0, Build 715a50.rhel73-1610101900
Red Hat Enterprise Linux Server release 7.3 Beta (Maipo)
[root@dafy19 tools]#

Version-Release number of selected component (if applicable):


How reproducible:
On this hardware, 100%

Steps to Reproduce:
1. run dmidecode as above (also fails with "dmidecode -p system-serial-number")

this is fixed with patch: (attached)
[PATCH] dmidecode: Hide irrelevant fixup message
commit: cff11afa886a0147d734b650755d232b5e7f2099 

from git://git.savannah.nongnu.org/dmidecode.git

Comment 1 Frank Ramsay (HPE) 2016-10-12 19:12:20 UTC
Created attachment 1209734 [details]
Patch that resolves issue.

Comment 3 Frank Ramsay (HPE) 2016-10-13 18:32:27 UTC
this looks like a regression; because 7.2 returns this:

[root@grommit ~]#  dmidecode -s chassis-type
Rack Mount Chassis

[root@grommit ~]# dmidecode -s system-serial-number
UV3000------

[root@grommit ~]# rpm -q dmidecode
dmidecode-2.12-9.el7.x86_64

[root@grommit ~]# uname -a
Linux grommit.engr.sgi.com 3.10.0-327.100hz.el7.x86_64 #1 SMP Wed Dec 16 10:27:50 EST 2015 x86_64 x86_64 x86_64 GNU/Linux

[root@grommit ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.2 (Maipo)

Comment 4 Russ Anderson 2016-10-13 18:33:07 UTC
And 7.3 returns this.

[root@cb13 ~]# dmidecode -s chassis-type
Main Server Chassis
Invalid entry length (16). Fixed up to 11.
[root@cb13 ~]#

Comment 7 Petr Oros 2016-11-04 13:48:06 UTC
Hi Frank,
Please, can you provide full output from latest dmidecode and binary dump of your dmi table by these commands:

$ dmidecode
$ dmidecode --dump-bin 

Thanks,
-Petr

Comment 8 Frank Ramsay (HPE) 2016-11-07 13:33:41 UTC
Created attachment 1218013 [details]
output from dmidecode dump-bin

attached output from dmidecode dump-bin

Comment 9 Frank Ramsay (HPE) 2016-11-07 13:34:45 UTC
Created attachment 1218014 [details]
output from dmidecode

attached full output from dmidecode.

Comment 12 Mike Gahagan 2016-11-08 14:58:27 UTC
providing QA ack as an OtherQA bug.

Comment 13 Frank Ramsay (HPE) 2016-12-05 18:26:15 UTC
Hey guys, is there any update on this?

-frank

Comment 16 Joseph Kachuck 2016-12-06 13:46:12 UTC
Hello,
This bug has been copied as 7.3 z-stream (EUS) bug #1401905

Thank You
Joe Kachuck

Comment 17 George Beshers 2016-12-22 16:17:25 UTC
Getting ready for OnBoarding first week of January.

Comment 19 George Beshers 2017-02-17 02:44:05 UTC
Tested on multiple machines inside SGI.

Comment 20 George Beshers 2017-02-17 14:04:07 UTC
Sorry for the noise.  Its much improved but the serial
number field still has an issue.

Comment 21 Frank Ramsay (HPE) 2017-02-17 14:39:18 UTC
Just to add to George's comment.

on sgi-uv300-02.rhts

# rpm -qa | grep dmidecode
python-dmidecode-3.10.13-11.el7.x86_64
dmidecode-3.0-3.el7.x86_64

chassis-type returns good

# dmidecode -s chassis-type
Rack Mount Chassis


but system-serial-number is wrong.

# dmidecode -s system-serial-number
UV3--------

# cat /proc/sgi_uv/system_serial_number
UV300-00000233


I'll leave this system up if you want to test this.  pwd 100yard-

Comment 22 Mike Gahagan 2017-02-17 16:15:25 UTC
Marking "FailedQA" as per comment 20 (system serial number is not being reported correctly)

Comment 23 Petr Oros 2017-02-28 08:22:46 UTC
#comment 21:
This is not bug in dmidecode

poros@holly$ ./dmidecode -t1 --from-dump /maintain/dmidecode-bin/UV300.bin
# dmidecode 3.0
Reading SMBIOS/DMI data from file /maintain/dmidecode-bin/UV300.bin.
SMBIOS 2.7 present.

Handle 0x0028, DMI type 1, 27 bytes
System Information
	Manufacturer: SGI
	Product Name: UV300
	Version: SGI
	Serial Number: UV3--------
	^^^^^^^^^^^^^^^WRONG SERIAL NUMBER^^^^^^^^^^
	UUID: 8B2C9555-5C8E-4221-BF48-DFF302443042
	Wake-up Type: Power Switch
	SKU Number: Not Specified
	Family: Server

poros@holly$ ./dmidecode -t2 --from-dump /maintain/dmidecode-bin/UV300.bin
# dmidecode 3.0
Reading SMBIOS/DMI data from file /maintain/dmidecode-bin/UV300.bin.
SMBIOS 2.7 present.

Handle 0x0029, DMI type 2, 17 bytes
Base Board Information
	Manufacturer: Silicon Graphics International
	Product Name: UV300
	Version: 5
	Serial Number: UV300-00000233
	^^^^^^^^^^^^^^^RIGHT SERIAL NUMBER^^^^^^^^^^
	Asset Tag: Base Board Asset Tag
	Features:
		Board is a hosting board
		Board is replaceable
	Location In Chassis: Part ComponentEnglish
	Chassis Handle: 0x0000
	Type: Unknown
	Contained Object Handles: 0

poros@holly$ hexdump -C /maintain/dmidecode-bin/UV300.bin | grep UV3
00000cb0  df f3 02 44 30 42 06 05  06 53 47 49 00 55 56 33  |...D0B...SGI.UV3|
00000cc0  30 30 00 53 47 49 00 55  56 33 2d 2d 2d 2d 2d 2d  |00.SGI.UV3------|
00000d10  6e 61 74 69 6f 6e 61 6c  00 55 56 33 30 30 00 35  |national.UV300.5|
00000d20  00 55 56 33 30 30 2d 30  30 30 30 30 32 33 33 00  |.UV300-00000233.|

For command "dmidecode -s system-serial-number":
  dmidecode using Type1 -> system serial number
  UV300-00000233 is baseboard serial number (Type2)
  
That means, dmidecode doing proper work, bogus is dmi data on system

Comment 24 Frank Ramsay (HPE) 2017-02-28 17:22:35 UTC
In light of comment 23 I'd say this is good to go in HPE's (was SGI) view.

Comment 25 errata-xmlrpc 2017-08-01 17:53:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1858

Comment 26 Massimiliano Torromeo 2017-09-07 10:18:53 UTC
It's fine to consider this as an issue with the dmi data but shouldn't the error message be printed on stderr?

The current behaviour is causing other tools using dmidecode to stop working correctly as they pick up the error message as part of the system informations.


Note You need to log in before you can comment on or make changes to this bug.