Bug 13842 - Crashed Installer on Sparc Ultra 5
Crashed Installer on Sparc Ultra 5
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
sparc Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-12 20:21 EDT by scottbeverly
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-14 14:16:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description scottbeverly 2000-07-12 20:21:11 EDT
(First I am not a Sun person, so help me out where I start to sound stupid)

The Beta3 installer can consistently be crashed on my Sparc Ultra 5 by 
performing the following steps:

- boot from the CDROM
- select "Next" on each screen until I reach the selection of partition 
method (i.e. Automatic, Disk Druid, etc...); it doesn't seem to matter 
which type of install I select (custom, workstation, etc).
- Then I select "Back" until I get to the Keyboard selection screen
- Next I select "Next" twice (once for keyboard and once for mouse 
selection)
  The system crashes and reboots back to the Prom

If I do a "stop-a" during the reboot I see error messages like:
-------
  Couldn't load XKB keymap, falling back to pre-XKB keymap
  The XKEYBOARD keymap compiler (xkbcomp) reports:
  > Error:       Can't find file "unknown" for geometry include
  >              Exiting
  >              Abandoning geometry file "default"
  Errors from xkbcomp are not fatal to the Xserver
  Error loading new keyboard description
  sending termination signals...done
-------
Then I can't see much more before it reboots, but it says something about 
rebooting and then something else.

Observations:

- When I first load the installer and select a keyboard the next screen is 
NOT the mouse selection Screen it is the "Redhat Linux Beta" graphic 
screen, but when I back up from the partition selection screen and then go 
forward I do get the mouse selection screen.
- I don't know which keyboard to select for my install (mostly because I am 
Sun hardware ignorant) -- The bottom of my keyboard says it is a "Type 6" 
which is not one of my options.
- My keyboard does NOT work correctly during the graphical installer -- 
e.g. if I press the '4' key it prints a '5' in the partition size box
- If I perform the same set of steps in the Text installer it does NOT 
crash and the system and the keyboard seems to work correctly (selecting 
the "sunkeymap" option for my keyboard.
Comment 1 Michael Fulbright 2001-09-14 14:16:23 EDT
SPARC is not a supported platform.

Note You need to log in before you can comment on or make changes to this bug.