This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 138423 - No audio from sound system - sound system OK
No audio from sound system - sound system OK
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks: FCMETA_ALSA
  Show dependency treegraph
 
Reported: 2004-11-08 22:23 EST by paul bateson
Modified: 2015-01-04 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-07 01:21:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
SBLive! Value alsa settings (40.17 KB, text/plain)
2004-11-15 08:20 EST, Sitsofe Wheeler
no flags Details
Results of 'alsactl -f test.state store' for SB Live! 1024 (44.38 KB, text/plain)
2005-02-21 13:29 EST, Neil Bird
no flags Details

  None (edit)
Description paul bateson 2004-11-08 22:23:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914
Firefox/0.10.1

Description of problem:
Good Day . . .

I just loaded fc3 then updated fc3 through yum. No audio is coming out
the speakers from any application. Same on KDE and GNOME. I checked
Kmix and ALSAMixer - no mute.

When I quickly move the slide volume controls on either of the above I
get crackling static and hum from the speakers at high volume. They
are active.

My sound card is listed in hardware and so is the correct driver,
Creative Labs SB LIVE! with the snd-emu10k1 driver.

I tried to "play" a WAVE file. No sound came out the speakers but I
could see my hard drive light blinking away at a fast rate. The
mechanics of playing the sound are working.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. play any sound
2.
3.
    

Actual Results:  no sound

Expected Results:  sound

Additional info:

My setup has worked with several other distributions. This is the
first problem that I have had with the sound. I don't know what to do!
Comment 1 paul bateson 2004-11-08 22:27:09 EST
Sorry about this. I forgot.

The test sound worked OK during the install process.
Comment 2 paul bateson 2004-11-08 22:35:58 EST
Once more. My apologises . . .

The sound worked prior to the update. Mail arrived and I heard the
announcement.
Comment 3 Bill Nottingham 2004-11-08 22:42:35 EST
If it's not muted, and it's not playing sound, that sounds like a
kernel issue.
Comment 4 Peter Zubaj 2004-11-10 09:36:31 EST
Are you sure, that your card is not in Digital mode ??? For analog
speakers "SB Live Analog/Digital Output Jack" and "IEC958 Optical Raw"
should be mutted.
Comment 5 paul bateson 2004-11-10 13:50:16 EST
Thank You for the reply.

ALSAmixer displays both your items but the controls are not enabled.
The app reports that the SB Live Analog/Digital Output Jack is OFF.

ALSAmixer has 47 controls. I will try and play with it from my end
while other investigations are active.

I cannot give this much time because I need the sound for my
teleconferencing. I'll give it a couple of days and then reinstall
Libranet 2.8.1. It is very, very old.

If anything pops up at your end please let me know.
Comment 6 Sitsofe Wheeler 2004-11-15 08:20:00 EST
Created attachment 106705 [details]
SBLive! Value alsa settings

Paul, (assuming you still have FC3) could you try saving the attached file and
then running
/usr/sbin/alsactl restore -f asound.state
and checking whether you can hear any sound. That file contains the current
settings that work for my sblive. Don't make the volume on your speakers too
loud before testing though though - I've set the master volume to be around
60-70%...
Comment 7 paul bateson 2004-11-16 13:07:17 EST
Good Day . . .

Thanx for the reply but unfortunately I have to replace the OS as soon
as this message goes out. I needed the sound for my conferences.

Keep up the good work.
Comment 8 bednar 2004-11-22 14:11:51 EST
I have similar problem and have no solution, look at:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=136082
Comment 9 Michael Olson 2004-12-11 18:20:38 EST
I had the exact same problem as paul.

Fresh install, worked durinf install test, up2dated, no sound - not
even in the sound card test. Everything acted like it was working, but
no sound.

Check alsamixer and wasn't muted, the ditial out ones mentioned above
were.

Downloaded the asound.state and applied it as instructed, sound
returned for me. Thanks.
Comment 10 Chris Leskiw 2005-01-12 17:21:25 EST
I had a similar problem when launching certain programs.  Xine for
example would work fine when launched from the command line, but when
launched from the task bar shortcut I created - the sound was crackly.
 TV-time had now audio, except for a loud hum...

My problems went away when I looked into how ESD was launching.  All I
ended up doing to solve the problem was to change the default sampling
rate to 48000.  I expected this to fix my xine problems, because I was
able to notice xine using the esd driver.  But to my pleasant
surprise, TV-time now works??!!
[my platform is x86_64]
Comment 11 Neil Bird 2005-02-18 10:31:50 EST
I've also been suffering this lack of sound since upgrading from FC2 a couple of
weeks ago;  I'll put some logs. below.  There's nothing in dmesg or
/var/log/messages that might indicate a problem.  Everything worked a treat
under FC2 (patched up to date);  I didn't try sound in between upgrading to FC3
and then bringing /it/ up to date with the latest RPMs.

The attached asound.conf above doesn't fix it for me, and gives:

alsactl: set_control:930: warning: name mismatch (PC Speaker Playback
Switch/Sigmatel Surround Playback Switch) for control #44
alsactl: set_control:930: warning: name mismatch (PC Speaker Playback
Volume/Sigmatel Surround Playback Volume) for control #45
alsactl: set_control:1025: bad control.45.value type

[ but other settings seems to change OK ]


$ lsmod
Module                  Size  Used by
usblp                  15937  0 
nvidia               3474748  12 
parport_pc             29701  1 
lp                     15405  0 
parport                37129  2 parport_pc,lp
nfsd                  185569  9 
exportfs                9921  1 nfsd
lockd                  59625  2 nfsd
md5                     8001  1 
ipv6                  236897  18 
autofs4                21828  1 
sunrpc                135077  19 nfsd,lockd
ipt_LOG                 9921  3 
iptable_filter          7489  1 
ip_tables              20929  2 ipt_LOG,iptable_filter
microcode              11489  0 
vfat                   16577  1 
fat                    41185  1 vfat
dm_mod                 57925  0 
uhci_hcd               33497  0 
snd_emu10k1_synth      10817  0 
snd_emux_synth         36289  1 snd_emu10k1_synth
snd_seq_virmidi        11073  1 snd_emux_synth
snd_seq_midi_event     11329  1 snd_seq_virmidi
snd_seq_midi_emul      10561  1 snd_emux_synth
snd_seq                51665  4
snd_emux_synth,snd_seq_virmidi,snd_seq_midi_event,snd_seq_midi_emul
snd_emu10k1            83909  8 snd_emu10k1_synth
snd_rawmidi            26849  2 snd_seq_virmidi,snd_emu10k1
snd_seq_device         12237  5
snd_emu10k1_synth,snd_emux_synth,snd_seq,snd_emu10k1,snd_rawmidi
snd_ac97_codec         68513  1 snd_emu10k1
snd_pcm_oss            51573  0 
snd_mixer_oss          21313  2 snd_pcm_oss
snd_pcm                89541  4 snd_emu10k1,snd_ac97_codec,snd_pcm_oss
snd_timer              27077  2 snd_seq,snd_pcm
snd_page_alloc         13509  2 snd_emu10k1,snd_pcm
snd_util_mem            8513  2 snd_emux_synth,snd_emu10k1
snd_hwdep              12997  2 snd_emux_synth,snd_emu10k1
snd                    54821  23
snd_emux_synth,snd_seq_virmidi,snd_seq,snd_emu10k1,snd_rawmidi,snd_seq_device,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
soundcore              12961  2 snd
tulip                  49761  0 
floppy                 56913  0 
ext3                  117961  6 
jbd                    57177  1 ext3


$ lspci
00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
00:09.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
00:09.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 07)
00:0b.0 Ethernet controller: Linksys NC100 Network Everywhere Fast Ethernet
10/100 (rev 11)
00:13.0 Unknown mass storage controller: Triones Technologies, Inc.
HPT366/368/370/370A/372 (rev 01)
00:13.1 Unknown mass storage controller: Triones Technologies, Inc.
HPT366/368/370/370A/372 (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200
Ultra] (rev a1)


$ system-config-soundcard
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 23 [74%] [on]
  Front Right: Playback 23 [74%] [on]
Playing WAVE '/usr/share/system-config-soundcard/sound-sample.wav' : Signed 16
bit Little Endian, Rate 44100 Hz, Stereo


All same symptoms;  everything seems to run OK, just ... no sound.
Comment 12 Peter Zubaj 2005-02-18 10:41:03 EST
Could you do:

alsactl -f test.state store

and attach test.state file.
Comment 13 Neil Bird 2005-02-21 13:29:20 EST
Created attachment 111268 [details]
Results of 'alsactl -f test.state store' for SB Live! 1024

Here 'tis.
Comment 14 Neil Bird 2005-02-27 12:53:05 EST
Good news, no explanation;  after the last jiggery pokery with alsactl
store/restore followed by an enforced power-down (coupla days; my monitor blew),
sound's returned OK.  Still suffer the muted sound at startup I've suffered
since FC2, but I can cope with manually running 'aslactl restore' once after
every infrequent reboot.

Ta for the help.
Comment 15 Dave Jones 2005-07-15 14:11:21 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.