Bug 138424 - new-kernel-pkg wrong param
new-kernel-pkg wrong param
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-08 23:11 EST by YOSHIMURA Keitaro
Modified: 2015-01-04 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-10 23:39:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description YOSHIMURA Keitaro 2004-11-08 23:11:53 EST
Description of problem:
 %post script was wrong.
 new-kernel-pkg wrong param.
 2.6.8-1.521: " --mkinitrd --depmod --install 2.6.8-1.521"
 2.6.9-1.667: " --package kernel --mkinitrd --depmod --install 2.6.9- 
1.667"

Version-Release number of selected component (if applicable):
 2.6.9- 1.667

How reproducible:
 remove " --package kernel"
Comment 1 Pete Zaitcev 2004-11-09 16:16:47 EST
What did actually happen because of "--package kernel"?
What did you do and what was the result?
Comment 2 Pete Zaitcev 2004-11-09 16:27:44 EST
Sorry, I understood it now. The new-kernel-pkg mkinitrd-3.5.22-1 (FC2)
does not have --package argument. The mkinitrd-4.1.18-2 (FC3) does.
Apparently, this is an issue when attempting to upgrade (the original
reporter used "agt-get dist-upgrade", ugh...)
Comment 3 YOSHIMURA Keitaro 2004-11-09 20:35:43 EST
yes. I used apt-get dist-upgrade.
# Did you see /.j?
It was wrong package dependency.
Comment 4 Dave Jones 2004-11-10 23:39:15 EST
mkinitrd needs to be updated first.
an anaconda update from fc2 -> fc3 should do this correctly.
if apt-get doesn't, it's a bug in apt-get afaics, as the
kernel spec already specifies a minimum mkinitrd of the
version in fc3 in its Requires:

Note You need to log in before you can comment on or make changes to this bug.