Bug 138426 - X server fails to refresh properly
X server fails to refresh properly
Status: CLOSED DUPLICATE of bug 132267
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-09 00:02 EST by Ed Holden
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Image of X server problem (211.07 KB, image/jpeg)
2004-11-09 00:10 EST, Ed Holden
no flags Details

  None (edit)
Description Ed Holden 2004-11-09 00:02:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3)
Gecko/20041001 Firefox/0.10.1

Description of problem:
Regardless of whether I am using KDE or GNOME, the X server has
trouble with windows, buttons and other elements of the GUI.  An
attachment I'll add shortly gives a oog picture of this.  As I move
windows around, the X server fails o redraw them properly.  Some
elements are invisible until you do something to change their
appearance, such as a button on a window that becomes brighter on
mouseover.

This problem first manifested itself in anaconda when I installed FC3.
 But not every time (installation took multiple attempts because of an
LVM-related issue).  But now that FC3 is installed, the problem
happens every time, making the system mostly unusable.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12

How reproducible:
Always

Steps to Reproduce:
1. Boot into runlevel 5.
2. Log into KDE or GNOME.  Watch as the GDM screen fails to completely
disappear whn the splash screen progresses.
3. Try your best to work when you can only see bits of the windows.

Actual Results:  X does not render windows well, and it renders some
elements only when you change their appearance.

Expected Results:  X should work perfectly and obey every whim of
every X client, with minimal complaints.

Additional info:
Comment 1 Ed Holden 2004-11-09 00:10:19 EST
Created attachment 106307 [details]
Image of X server problem

This is a good example of the X server refresh problem.  There application at
center is up2date, which is almost unusable because most of the operative bits
of the window are missing.  At left you can see parts of the K menu in the
up2date window, which were left behind as artifacts.
Comment 2 Ed Holden 2004-11-09 18:42:28 EST
I have managed to get itto work on low reolutions, but not reliably. 
Basically I have to set it to use an unsupported graphics card.  Then
when I start X again it has an error and reconfigures X.  It then
works on 800x600, but not reliably.  I'm certain that it has the right
driver, an Intel i810, and I'm setting it to use thousands of colors.
Comment 3 Marcelo Diotto 2004-11-11 05:42:50 EST
I am having the same proble,  i have an i815 graphics caard and the
screen don't refresh properly!!!!
I'm searching for a help too. If i found something usefull i'll post here!
Comment 4 Fuji TSO 2004-11-11 13:48:33 EST
I just ran into this on a Dell GX110 with an Intel i810 graphics chip.

If I copy the i810_drv.o from Fedora Core 2, it seems to work fine.
With the FC3 i810_drv.o, I get the refresh problem described in this
bug (I got the idea to try that from
https://freedesktop.org/bugzilla/show_bug.cgi?id=1455)
Comment 5 Ed Holden 2004-11-12 12:18:58 EST
That's a very good idea.  I just secured a copy of that file from my
laptop, and may try it.  However in the mean time I have had to get
work done, so I've installed another distro for the short term and I
may not be able to verify that this works on my system anytime soon. 
But it's a good suggestion and I'll hang onto that copy of the file. 
Presumably it confirms that this is indeed an Xorg problem, not
something with the kernel.
Comment 6 Richard Rager 2004-11-13 19:28:43 EST
I have the same problem with a Dell Inspiron 2500 same driver i810. 
With Fodora Core 3.  Fresh install.  The is somethink I was having
problems with in devel of FC3 should be links with the beta bug
Comment 7 Dennis Bautell 2004-11-16 00:54:31 EST
I tried running setup to change the screen resolution. (From within X
all my modes weren't available) setup kept failing to run the xconfig,
or whatever, so I switched to runlevel 3. Then I was able to use setup
to set the res and color depth (24 bit, and 1400x1050 & 1280x1024 work)

Now when I set the runlevel back to 5, it failed hard, xserver
crashing suddenly and leaving me with nothing but garble (Unknown if
this was causal or if I meddled with the wrong stuff)

So that's where I am, runlevel 3, startx, and the whole deal seems to
be working. Tomorrow I'll try runlevel 5 again.
Comment 8 Peter Fales 2004-11-16 15:12:58 EST
Same thing here - fresh install of FC3 - i810 hardware
Comment 9 Peter Fales 2004-11-16 15:22:49 EST
For the record, adding 

  Option "No Accel"

to the "Device" section seems to be another workaround
Comment 10 Dennis Bautell 2004-11-16 17:10:18 EST
OK, so overnight I changed nothing, but the problem came back. Go figure.

Option "No Accel" goes where? xorg.conf? Imunna go try that.
Comment 11 Phil Anderson 2004-11-19 22:24:26 EST
I'm getting the same thing here on my Dell Dimension 2100 - a very
common model over here in Australia, featuring a i810 chipset.

Had to do text install as it was unusable.

Setting NoAccel fixes the problem.

Comment 12 Kristian Høgsberg 2004-11-23 15:55:44 EST
This issue is duplicate of bug #132267 for which we have a fix
available in rawhide (xorg-x11-6.8.1-17).  We will probably issue an
FC3 udpate shortly, which will also provide a fix for Fedora users.

*** This bug has been marked as a duplicate of 132267 ***
Comment 13 Red Hat Bugzilla 2006-02-21 14:06:50 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.