Bug 138429 - Indic glyphs are misalign to some roman glyphs
Indic glyphs are misalign to some roman glyphs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
bzcl34nup
: i18n, Reopened
Depends On:
Blocks: Indic
  Show dependency treegraph
 
Reported: 2004-11-09 02:25 EST by Leon Ho
Modified: 2008-05-06 10:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 10:57:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
misaligned example screenshot (54.57 KB, image/png)
2004-11-09 02:26 EST, Leon Ho
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 327163 None None None Never

  None (edit)
Description Leon Ho 2004-11-09 02:25:17 EST
Description of problem:
Indic glyphs are misalign to some roman glyphs after indic have been
resized. Please see the attachment for the sample. It seems related to
either freetype, pango, or the font. Let me know if I have submit the
wrong one.

How reproducible:
everytime

Steps to Reproduce:
1. LANG=hi_IN.UTF-8 evolution
2. New mail
  
Actual results:
different translations is misaligned to each other

Expected results:
should be aligned

Additional info:
Comment 1 Leon Ho 2004-11-09 02:26:10 EST
Created attachment 106314 [details]
misaligned example screenshot
Comment 2 Mike A. Harris 2005-06-02 17:26:31 EDT
Moving to FC5Target, as FC4 is 'done', barring release blockers that
pop up.
Comment 3 Liang Zhang 2005-11-23 03:35:22 EST
I have compared some Indic strings with English and Chinese strings, it seems
that English and Chinese are rendered aligned to the middle, but Indic string
aligned to the top in pango. 
I am not sure if this is desired Indic behavior, but this is a what pango does.

Any indic native speaker could confirm this?
Comment 4 Ray Strode [halfline] 2006-01-11 15:50:31 EST
Can you guys file this upstream and post the bug to this report? thanks.
Comment 5 Leon Ho 2006-01-17 02:41:11 EST
Lawrence has submitted this: http://bugzilla.gnome.org/show_bug.cgi?id=327163
Comment 6 Christopher Aillon 2006-01-27 15:50:08 EST
this is upstreamde now.
Comment 8 Matthias Clasen 2006-02-10 01:06:48 EST
The problem we are seeing here is simply that the indic and latin fonts which
are used have wildly different ascent/descent. GTK+ does not do any kind of
baseline alignment in situations like this, so text will only line up if the
ascent/descent of all involved fonts are relatively similar
Comment 9 Matthias Clasen 2006-02-10 14:33:13 EST
Not fixable in fc5 timeframe.
Comment 10 Red Hat Bugzilla 2007-02-05 13:58:40 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 11 Bug Zapper 2008-04-03 11:45:24 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 12 Jens Petersen 2008-04-30 20:32:29 EDT
Rahul, could you take a look if this is still a problem?
The upstream bug is still open at least.
Comment 13 Rahul Bhalerao 2008-05-01 05:42:03 EDT
This was a problem with the auto-hinting done by freetype. Now that problem has
been solved since freetype-2.3.5. So this bug does not exists any more.We may
safely close this one.
Comment 14 Matěj Cepl 2008-05-06 10:57:49 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.