Bug 138430 - Fedora Core 3 prompts Assertion at disk_dos.c during the very first stage of install
Fedora Core 3 prompts Assertion at disk_dos.c during the very first stage of ...
Status: CLOSED DUPLICATE of bug 138419
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-09 02:53 EST by Edwin Chan
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edwin Chan 2004-11-09 02:53:42 EST
Description of problem:

When installing Fedora Core 3, I am unable to perform any actions 
with the installer, the installer just keep prompting:

Assertion (heads > 0) at disk_dos.c:485 in function 
probe_partition_for_geom() failed.
Assertion (sectors <= 63) at disk_dos.c:490 in function 
probe_partition_for_geom() failed.

install exited abnormally.

After going pass the language selection screen.



The system has 2 IDE harddisks and they have the following partition 
information:

Disk /dev/hda: 255 heads, 63 sectors, 20023 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *       257       260     32130   83  Linux
/dev/hda2             1       256   2056288+  82  Linux swap
/dev/hda3           261      7272  56323890   83  Linux
/dev/hda4          7273     20023 102422407+  83  Linux

Partition table entries are not in disk order

Disk /dev/hdb: 255 heads, 63 sectors, 30401 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hdb1             1      1274  10233373+  83  Linux
/dev/hdb2          1275      1339    522112+  82  Linux swap
/dev/hdb3          1340      5036  29696152+  83  Linux
/dev/hdb4          5037     30401 203744362+  83  Linux




How reproducible:
Always.

Steps to Reproduce:
1. Put in the Fedora Core 3 CD-ROM in the CD-ROM drive
2. Reboot the system.
3. Select the language and then click Next

  
Actual results:
Assertion, install exited abnormally.

Expected results:
Perform installation/upgrade.
Comment 1 VnPenguin 2004-11-09 03:13:12 EST
I have the same error when doing fresh installation. When I click on
"Ignore" the installation exited. When I click on "Cancel" the
installation continues but exited later after selecting packages.

On the same hdd, I can install without any problem FC1, FC2, Slackware
10.0 and SuSE 9.1.

Any solutions ?
Comment 2 Edwin Chan 2004-11-09 03:27:13 EST
The system motherboard is Asus P4P800 Deluxe, hard disks are Hitachi 
IDE 250GB(HDS722516VLAT80) and IDE 160GB(HDS722516VLAT80), using 
onboard IDE controller:

ICH5: IDE controller at PCI slot 00:1f.1
PCI: Enabling device 00:1f.1 (0005 -> 0007)
ICH5: chipset revision 2
ICH5: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xfc00-0xfc07, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xfc08-0xfc0f, BIOS settings: hdc:DMA, hdd:DMA
hda: HDS722516VLAT80, ATA DISK drive
hdb: HDS722525VLAT80, ATA DISK drive
Comment 3 Jeremy Katz 2004-11-09 12:59:01 EST
Can you try the update image at
http://people.redhat.com/~katzj/fc3-part-upd.img and see if that helps?

(Instructions for using an update disk are available at
http://rhlinux.redhat.com/anaconda/updatedisks.html)

*** This bug has been marked as a duplicate of 138419 ***
Comment 4 Simrat 2005-04-09 13:37:28 EDT
(In reply to comment #0)
 Description of problem:
 When installing Fedora Core 3, I am unable to perform any actions 
 with the installer, the installer just keep prompting:
1) Assertion (heads > 0) at disk_dos.c:485 in function 
 probe_partition_for_geom() failed.
2) Assertion (sectors <= 63) at disk_dos.c:490 in function 
 probe_partition_for_geom() failed.
 install exited abnormally.
 After going pass the language selection screen.
 The system has 1 IDE harddisk and have 5 dos partitions

 On my Harddisk (samsung make 40GB) following information is printed:
    LBA  78-242-976
Now which figure represents cylinder, head and sector, and how can i resolve 
this problem, please someone tell me. 
(My email id "simrat.khokhar@gmail.com")

 Actual results:
 Assertion, install exited abnormally.

 Expected results:
 Perform installation/upgrade.

Comment 5 Red Hat Bugzilla 2006-02-21 14:06:51 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.