Bug 138433 - ia32el fails to compile with new gcc
Summary: ia32el fails to compile with new gcc
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ia32el (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: ia64 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-09 09:00 UTC by Yoav Zach
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-13 18:11:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixes the problem of compiling with new gcc (2.45 KB, patch)
2004-11-09 09:03 UTC, Yoav Zach
no flags Details | Diff

Description Yoav Zach 2004-11-09 09:00:37 UTC
Description of problem:
when trying to build ia32el with gcc that ships with rhel4 we hit 
some minor problems, which made the compilation fail.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Yoav Zach 2004-11-09 09:03:04 UTC
Created attachment 106317 [details]
fixes the problem of compiling with new gcc

Comment 2 Jakub Jelinek 2004-11-09 09:54:20 UTC
The ia32el srpms have this fixed already (by removing inline keyword where
it should not be used as the function really is not inlinable).
See ia32el-gcc34.patch patch.

Comment 3 Yoav Zach 2004-11-09 11:31:52 UTC
we considered this solution and prefer to remove the -Winline switch. 
can you please reconsider it ?
thanks,
yoav.

Comment 4 Jakub Jelinek 2004-11-09 12:59:17 UTC
Curious, why you think removing -Winline is better?
IMHO it is quite useful warning, if you have code that you intend to be inlined,
it helps you ensure it really is inlined.
What purpose is for the inline keyword on functions that really can't be inlined
(they don't have function bodies defined in the header that has the inline
keywords nor anything else that is included in the .c files that are using
these routines)?

Comment 5 Yoav Zach 2004-11-09 13:36:51 UTC
the argument was that it depends on the compiler, whether a function 
can be inlined or not. and we don't want to get into a situation 
where we need to change the sources for each new version of gcc (or 
intel compiler when we'll start using it).

Comment 6 Jakub Jelinek 2004-11-16 12:52:35 UTC
It seems the noaltroot patch was already removing -Winline.
Anyway, I have added the patch as is and removed from noaltroot the same hunks
(because on RHEL3 noaltroot patch is not applied).

Comment 7 Jay Turner 2005-01-13 18:11:07 UTC
Intel, closing this out, as it hasn't come up in recent discussions.  Please
reopen if the problem is still present.


Note You need to log in before you can comment on or make changes to this bug.