Bug 138435 - system config tool doesnt work with fc3 dvd installation disk
Summary: system config tool doesnt work with fc3 dvd installation disk
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-packages (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-09 09:34 UTC by clark
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 19:51:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description clark 2004-11-09 09:34:36 UTC
Description of problem: when selecting to install extra programs using
 the add/remove programs tool it asks for Fc3 disk 2 at the begining
of the install phase of this program


Version-Release number of selected component (if applicable):1.2.20-1


How reproducible: have a fc3 dvd use the add/remove programs tool
select a program thats on the fc3 core disk 2 to install click update 
error occors

Steps to Reproduce:
1. use FC3 Dvd
2. launch add/remove programs in the system settings menu under gnome
3. select a program to install thats on the fc3 disk 2
4. click update it will show a compleated systems prep window click
continue
5. error occours
  
Actual results:
Window comes up asking saying "fedora core 3" disk 2 is needed to be 
installed 
Expected results:
the program to continue installing the packages you selected to install

Additional info:

Comment 1 Jeremy Katz 2004-11-09 14:46:23 UTC
If you press OK with the DVD in, it should continue.  The DVD is
basically all of the CDs

Does this not occur?

Comment 2 clark 2004-11-09 23:00:01 UTC
it doesn't allow you to continue it still asks for the  "fedora core
3" disk 

Comment 3 clark 2004-11-10 07:25:03 UTC
i recently put my fc core dvd disk in  dev/cdrom and it worked
however this so happens to be my extenal dvd writer. my interal dvd
drive doesnt not work with this because it is another dvd drive. it is
able to read and do other things with this dvd. this  program should
be able to use both drives and it not matter which drive i put the
disk in.

Comment 4 jh 2004-11-13 15:13:38 UTC
I have a DVD writer at /dev/hdb and a CD-ROM drive at /dev/hdc. When
running system-config-packages from the command line, with the
installation medium inserted and mounted, I get:

exception while mounting: (123, 'No medium found')
looking for me in /etc/mtab
dev is: /dev/hdc, where is: /media/cdrom1

followed by the contents of /etc/mtab, including:

/dev/hdb /media/cdrom iso9660
ro,nosuid,nodev,fscontext=system_u:object_r:removable_t 0 0


Comment 5 Paul Vandenberg 2004-11-23 01:24:49 UTC
I have a similar problem. I can install stuff from my DVD with
system-config-packages, the first time I use it after each time I
boot. After that, it keeps complaining that it can't access my disk.
If I reboot, all is OK when I load system-config-packages and do
another install. If I exit, and then try to install another package, I
get 'Unable to access disk.' again.

Paul

Comment 6 Armijn Hemel 2004-12-04 23:08:55 UTC
Regarding comment #5, I'm seeing that too. Restarting haldaemon seems
to fix that, but it has to be done over and over again. I think this
is a different bug though.

Comment 7 Adriaan 2005-02-06 12:28:38 UTC
I have a problem installing FC3 from the DVD version...on the 
Installation Method there is no option to select my DVD as source.  
When Local CDROM is selected I get a 'CD Not Found' error...

All my hardware works 100%

Please help - I searched the forums but could find any resolution for 
this

Adriaan

Comment 8 Peter 2005-02-23 18:52:28 UTC
When I boot from the DVD, the FC3 installation starts just fine. 
However, when it asks which drive the packages are on, it doesn't
offer the DVD as an option.

CDROM,
HARD DRIVE,
NFS,
HTTP, 

but no DVD

This is a show stopper for DVD installations.

Comment 9 Jeremy Katz 2005-09-21 19:51:32 UTC
This should be better for newer releases


Note You need to log in before you can comment on or make changes to this bug.