Bug 138442 - Booting 2.4.21-20ELsmp kernel with QLA2344 board takes ages
Booting 2.4.21-20ELsmp kernel with QLA2344 board takes ages
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-11-09 05:45 EST by Thomas Bub
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-12-22 16:52:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Here is the requested messages after the long boot period. (264.55 KB, application/x-gzip-compressed)
2004-11-10 10:16 EST, Thomas Bub
no flags Details

  None (edit)
Description Thomas Bub 2004-11-09 05:45:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
The booting of an RedHat EL 3.0 kernel 2.4.21-20ELsmp takes ages (40 
minutes)if all 4 channels of an QLogic QLA2344 4 port FC-2 board are 
This does not happen if only the first 2 of the 4 ports are populated.
This does also not happen with all 4 ports if a "Non smp" kernel like 
2.4.21-20EL is used.
The QLA2344 board does have the latest QLogic firmware 1.43 but did 
also happen with the old one 1.34.
I tried the same proceudre with the latest QLogic drivers 7.0. but 
with the same results.

In addition only the disks on the first 2 ports are introduced to the 
OS when having wait thoose 40 minutes.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Install QLogic QLA2344 board
2.Boot an EL 3.0 smp kernel 

Actual Results:  Booting takes about 40 minutes.
Only the disks on the first 2 ports are introduces to the OS.

Expected Results:  Botting takes 2 minutes.
The disks on all 4 ports are introduced to the OS.

Additional info:
Comment 1 Tom Coughlan 2004-11-10 09:03:10 EST
It sounds like an interrupt routing problem.  The system is scanning
for devices on the second two ports, and each one times out waiting
for a command completion interrupt that never comes. Please try
booting the smp kernel with "noapic" on the kernel command line. Also,
please post /var/log/messages for the 40 minute boot case.

Comment 2 Thomas Bub 2004-11-10 10:16:53 EST
Created attachment 106418 [details]
Here is the requested messages after the long boot period.
Comment 3 Thomas Bub 2004-11-10 10:19:14 EST
The proposed try with noapic on the smp kernel worked.
What are the consequences of using noapic ?
Is the preformance going down on this ?
Comment 4 Tom Coughlan 2004-11-11 10:34:05 EST
There might be a small performance impact in a very high interrupt
environment. From what I have read, this is not typical.

You should check to see if there is a BIOS update for your system. And
check with the manufacturer to see if this is a known problem. 

Did something change that caused this problem to show up? Was it just
the addition of the QLA2344? 
Comment 5 Thomas Bub 2004-11-12 07:06:08 EST
I'm running the latest Bios versions on the HP xw8000 workstation 
mainboard and the QLogic board.
I'm in contac´t with QLogic already.
The problem occurs as soon as a second pair of FC-2 loops comes into 
play either a second QLA2342 Dual-Port FC-2 card or a single QLA2344 
Quad-Port FC-2 board. Where the QLA2344 is nothing more then 2 x 
QLA2342 behind a PCI-X bridge chip.
Comment 6 Thomas Bub 2004-11-24 02:10:26 EST
I got the tip from QLogic that the APIC implementation of the 
mainboard bios might be the root cause of the problem.
They asked me to go back to MPS 1.1 form 1.4 in the mainbaord bios if 
possible. Unfortunately my mainboard bios does not allow to do this.
Is there a way to tell the Linux kernel to use only MP1.1 instead ?

Another information I got the successor of the HP xw8000 called 
xw8200 where the problem does not persist anymore. However I need a 
solution for our installed base on HP xw8000.
Comment 7 Tom Coughlan 2004-12-22 16:52:39 EST
No, I don't know of a way to tell the Linux kernel to use only MP1.1.
Maybe HP can help. 

As fas as I know, the noapic workaround is safe. I'll close this BZ.
Re-open if there is something more we can do to thelp here. 

Note You need to log in before you can comment on or make changes to this bug.